Row attribute on textarea element display one too many rows

RESOLVED DUPLICATE of bug 33654

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 33654
13 years ago
13 years ago

People

(Reporter: Tim L, Unassigned)

Tracking

({testcase})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUP of bug 33654)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.40607)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414

If I set the row attribute on the html textarea form element to say the value 
5, you can actually see 6 rows on the web page.  I have tried to lower the 
number to 4, then I saw 5 rows.  There is one more row being displayed than I 
typed into the row attribute.

Reproducible: Always

Steps to Reproduce:
<textarea rows="5" cols="40">
1
2
3
4
5
6
</textarea>
Actual Results:  
I can see row 6 on the screen

Expected Results:  
I should only see rows 1 to 5, with row 6 being outside of the current 
viewport.

I have reproduced this in Mozilla 1.7.7 and Firefox 1.0.3.

The only work around that I have at this stage to obtain cross browser 
compatability with IE and Opera is to set the height with CSS to a fixed value.
Can you attach a testcase ? (using the create new attachment link in this bug)
(Reporter)

Comment 2

13 years ago
Created attachment 181375 [details]
HTML to replicate the issue

Comment 3

13 years ago
I believe this is a duplicate of bug 33654
Whiteboard: DUP of bug 33654
(Reporter)

Comment 4

13 years ago
Its possible its a duplicate.  I did search for duplicates but didn't come 
across that one in my search.

This problem I'm reporting though is based on the default font.  Bug 33654 
seems to be related more to variable width font, wheras the default font is 
monospaced.  Hence I would have thought it would be easy to calculate the line 
height thereby calculate the box height.

At a guess, I would say that its allowing for the height of the horizontal 
scrollbar when the default wrapping behaviour doesn't allow for the horizontal 
scrollbar to exist at all.

Updated

13 years ago
Keywords: testcase
*** Bug 291356 has been marked as a duplicate of this bug. ***

Comment 6

13 years ago
Reading bug 33654, I still think this is a dupe. Feel free to disagree and
reopen :).

*** This bug has been marked as a duplicate of 33654 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.