Support N-Level classifications

NEW
Unassigned

Status

()

P4
enhancement
14 years ago
5 years ago

People

(Reporter: altlist, Unassigned)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041223 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041223 Firefox/1.0

My company is getting bigger, to the point where it would be nice if there was
N-Level classification support, where the admin defined how many levels.  

I believe this could be done by adding a "level" column in the classification
level and the "id" column would point to either a class_id or product_id (for
level 0).  

The advanced query would have to be updated, but I don't think any of the
reports/graphs would have to change.  


Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
To make this really practical, bug #277080 would have to be implemented.
Depends on: 277080

Comment 2

14 years ago
Hrm, did we not already have this filed somewhere?? I'd think this is a dupe...
(Reporter)

Comment 3

14 years ago
BTW, similar to #277080, I'd like to see multiple classificiations with the same
name in different classifications.

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 43940 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 5

13 years ago
These bugs are *not* duplicates of each other.

The ability to have an infinite level of classifcations is not the same as
having *one object type* which represents them all.

Perhaps the summaries are not fully clear.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 6

13 years ago
Oh, wait, I just actually *looked* at the bug this was duped to.

No, component trees are extremely complex and unnecessary. I much prefer N-Level
Classifications.

Comment 7

13 years ago
*** Bug 320227 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 8

12 years ago
My company currently has 300+ products and could easily increase several times.  As such, having a N-level classification (combined with bug #277080) would be a big win.  Classification-wide reports, groups, etc. would also be a big win.  This is a more enterprise class of features. 

I know this is a lot of work, but it's what my company is now looking for.  
Whiteboard: [roadmap: 3.2]

Updated

12 years ago
Whiteboard: [roadmap: 3.2]
(Reporter)

Comment 9

9 years ago
Turns out my company didn't need N-level classification per se, we
only needed the ability to easily find and enter new bugs.  My
solution was to support a pseudo N-level classifications and N-level
products by doing following:

  - Support a menu bar (via YUI 2.x), where one can enter/search/edit 
    products/classifications using a N-level hierarchical menus
  - Create the classification/product hierarchy by doing a split(' : ',$name)

For example:

   Product-A
    - Classification:   Level1 : Level2a
    - Product:          SubLevel1 : SubLevel2 : Product-A
   Product-B
    - Classification:   Level1 : Level2b
    - Product:          Foo : Bar : Product-B
   Product-C
    - Classification:   Level1 : Level2b
    - Product:          Foo : Bar : Product-C

The "New Ticket" hierarchical menu would then look like:

   New-Ticket
      Level1
        Level2a
          SubLevel1
            SubLevel2
              Product-A
        Level2b
          Foo
            Bar
              Product-B
              Product-C

With 1500+ products, having a n-level menu hierarchy greatly
simplified the ability to create new tickets as one can quickly find
the product without any mouse clicks.

I'm also using the same hierarchy to do searches.  Clicking on any level
in the hierarchy will display all open tickets at that level.  For
example, clicking on "level2b" will find all tickets tied to level2b
(products B and C).

As a result, my enter_bug page has the following:

  - In the menu bar, three hierarchical menu's
    - Enter New Ticket
    - Search
    - Edit Products
  - For moving tickets
    - Replace the product pulldown with another hierarchical menu.

Mind you, while I have four hierarchical product menu's, you only need
to define the hierarchy structure once on the server side.  Use javascript
to auto-generate the four menu's on the client side.

Last, this "solved" bug 277080, where one can now have the same
product name in multiple classifications due to the pseudo hierarchy.

Granted, this requires a YUI-like javascript package.
(Reporter)

Comment 10

9 years ago
I forgot, one can also add a hierarchical menu to indicate which product for cloning a ticket.

Comment 11

9 years ago
That's an interesting solution. I don't think it's exactly what we'd do upstream, but it's something to think about.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

9 years ago
Priority: -- → P4
You need to log in before you can comment on or make changes to this bug.