Proxy wildcards when specifying server names or ip ranges

RESOLVED INVALID

Status

()

Firefox
Preferences
RESOLVED INVALID
13 years ago
11 years ago

People

(Reporter: Rayno Burger, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

Say a company uses an IP range of 10.x.x.x.

1.  Is there any way to bypass the proxy server for the whole range of any IP
addresses that starts with 10?

2.  How do you specify to bypass server names...  For example bypass all server
names that starts with na- or za-?

Thanks in advance
Rayno

Reproducible: Always

Steps to Reproduce:
1. Add 10./24, za-, na- to the "Do not use proxy" setting.
2. Opened a website that starts with http://10 or http://za- or http://na-


Actual Results:  
The sites were not loaded because the proxy server cannot access those sites.

Expected Results:  
The proxy server settings should have been ignored.

Comment 1

13 years ago
Reporter, this isn't a support forum. If you want support, go to
<http://forums.mozillazine.org/>

> 1.  Is there any way to bypass the proxy server for the whole range of any IP
> addresses that starts with 10?

It's mentioned in the example (192.168.1.0/8) ! In your case : 10.0.0.0/24
(which  is identical to 10.*.*.*)

> 
> 2.  How do you specify to bypass server names...  For example bypass all server
> names that starts with na- or za-?

.domain.com works, but that has the wildcard on the left.

> 
> Thanks in advance
> Rayno
> 

Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Comment 2

13 years ago
or create your own pac file which can do just about anything.
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.