Closed Bug 291285 Opened 15 years ago Closed 15 years ago

<canvas> with no width/height crashes

Categories

(Core :: Canvas: 2D, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED FIXED

People

(Reporter: ian, Assigned: vlad)

References

()

Details

(Keywords: crash, testcase)

A <canvas> element with no width/height attributes crashes. It should default to
300x200, I believe.

TESTCASE:
http://www.hixie.ch/tests/adhoc/html/canvas/002.html
Assignee: nobody → vladimir
Severity: major → critical
Keywords: testcase
I can't reproduce this on Gecko/20050418 WinXP (Firefox 1.0+).
Component: Layout: Misc Code → Layout: Canvas
fixed by checkin for bug 260120 -- there's now a default that's used in case a
size is invalid.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.