Splitter (grippy) drag action badly broken

RESOLVED DUPLICATE of bug 290494

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED DUPLICATE of bug 290494
13 years ago
13 years ago

People

(Reporter: Patrick, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Mouse UI controls are badly broken on the trunk for OS X builds.


This shows in various ways: using a Mac OS X nightly from any of the days listed
below, try any of the following.

1) using classic view, take a message from the inbox (top right pane) and try to
drag it to a folder in the left-hand pane. The folder that is highlighted is
about 2cm off from the actual mouse position. 
2) take the grippy to resize the left-hand pane, and move it to the left -> the
divider moves to the RIGHT.
3) take the gripppy to resize the message preview pane. Resizing is impossible
as the pane immediately collapses and is impossible to bring back with mouse
movements.

version  (20050412)  --> OK
version  (20050414)  --> OK

version  (20050416)  --> broken
version  (20050417)  --> broken


Marking this as Major.

Comment 1

13 years ago
(In reply to comment #0)
> 1) using classic view, take a message from the inbox (top right pane) and try
> to drag it to a folder in the left-hand pane. The folder that is highlighted
> is about 2cm off from the actual mouse position. 

Bug 290744, duped to bug 290494, fixed.



> 2) take the grippy to resize the left-hand pane, and move it to the left ->
> the divider moves to the RIGHT.

Also, even if you move to the right, the movement of the splitter is 
'accelerated' compared to the mouse movement.

> 3) take the gripppy to resize the message preview pane. Resizing is impossible
> as the pane immediately collapses and is impossible to bring back with mouse
> movements.

I reproduced both (2) and (3) with Moz 1.8b2-0417, Win2K.  There is a similar 
problem with the splitter in the Moz browser window between the page and the 
sidebar, but not as drastic.

However, the problem is cleared up with Moz 1.8b2-0422.  Looking at the 
description of the patch, it's the same problem, so duping; but also 
resummarizing in case anyone searches on this particular symptom.

*** This bug has been marked as a duplicate of 290494 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
OS: MacOS X → All
Hardware: Macintosh → All
Resolution: --- → DUPLICATE
Summary: mouse controls are badly broken → Splitter (grippy) drag action badly broken
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.