Firefox doesn't do word-wrapping after "-" in Tables/<TD>s

VERIFIED DUPLICATE of bug 95067

Status

()

defect
--
trivial
VERIFIED DUPLICATE of bug 95067
14 years ago
14 years ago

People

(Reporter: bkramer, Assigned: bugzilla)

Tracking

({testcase})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

The Firefox-Browser 1.03 (an all versions before) doesn't do word-wrapping in 
words divided by "-". Example: If the word "Software-Development" is to wide 
for the <TD> it's displayed in, it will expand the whole Table (which is a 
correct behavior if "Software-Development" is handled as one word). In most 
(all?) western languages it's usual that the "-" is used as a divider. That's 
why word-wrapping would make much more sense in this case (-> "Software-[next 
line]Development").

Reproducible: Always

Steps to Reproduce:
1. Create a table (1 column, 1 row) which - in the font-size you are using - 
is just wide enough to display the Word "Software".
2. Paste the Text "Software-Development" into the <TD></TD>-Tag.
3. Test this table in IE and Firefox.
Actual Results:  
Firefox didn't do word-wrapping, IE did.

Expected Results:  
Display the word "Software-" in the first line, "Development" in the second 
line.
Posted file testcase
testcase shows current and proposed behaviour.
Keywords: testcase

*** This bug has been marked as a duplicate of 95067 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 3

14 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.