Big memory leak in "Search Messages"

VERIFIED INVALID

Status

MailNews Core
Backend
P1
normal
VERIFIED INVALID
20 years ago
10 years ago

People

(Reporter: Nelson Bolyard (seldom reads bugmail), Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(This bug imported from BugSplat, Netscape's internal bugsystem.  It
was known there as bug #331914
http://scopus.netscape.com/bugsplat/show_bug.cgi?id=331914
Imported into Bugzilla on 02/04/99 16:36)

When I search through "local mail" for a message, the VM space in my
application grows by many megabytes.  When close the search window
and the related folder windows, the VM size does not decrease.
After several searches, Communicator was using over 100 Megabytes of VM
and was misbehaving (probably out of memory).

I downloaded the US version of 4.5 off of the external web site today,
and reproduced the problem with that version.

I searched for messages with date after 9/26/98, sender contains
netscape.com and body contains dejanews.  My folders total 87 megabytes
(including txt and .snm files).

Comment 1

20 years ago
Ouch.  Asigning to Phil.

Comment 2

20 years ago
adding myself to cc: list.

Comment 3

20 years ago
I've been playing with this a little, and I do see VM growing a couple
megs sometimes when searching, but not always. Purify doesn't report substantial
leaks or memory in use, so I'm not sure what this memory is being allocated for.
Will keep looking into it.

Comment 4

20 years ago
Doesn't meet marek's 4.51 criteria. TFV 5.0

Updated

20 years ago
QA Contact: 4112

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 5

19 years ago
Don't know who's doing Search for 5.0 yet. Accepting bug to myself to shut up
terry's bugzilla notification bot.

Updated

19 years ago
Target Milestone: M8

Updated

19 years ago
Target Milestone: M8 → M11

Comment 6

19 years ago
won't be fixed for a while, since search is not implemented yet.

Updated

19 years ago
OS: Windows NT → All
QA Contact: laurel → suresh
Hardware: PC → All

Comment 7

19 years ago
changing platform from PC to All since this bug, if still exists, would need to
be checked on all platforms.

Change QA contact to Suresh since he can verify the bug, once fixed.

Comment 8

19 years ago
Search won't be implemented in Beta 1, so this bug does not need to be fixed
until after Beta 1

Comment 9

19 years ago
Search won't be implemented in Beta 1, so this bug does not need to be fixed
until after Beta 1

Updated

19 years ago
Assignee: phil → mscott
Status: ASSIGNED → NEW
Target Milestone: M11 → M14

Comment 10

19 years ago
mscott owns the search backend for 5.0, so reassigning to him for M14

Updated

19 years ago
Target Milestone: M14 → M17

Comment 11

19 years ago
this bug is on the "Most Frequent Bugs" page on
http://www.mozilla.org/quality/most-frequent-bu
gs/
which makes no sense because we don't even have a search front end.

Send mail to leger to get it off
It'll be off in the next update ;-)

Gerv
(Assignee)

Comment 13

18 years ago
Killing off this bug as invalid for seamonkey. We are re-writing our search
backend in 6.0. We may introduce a new big memory leak but we probably won't
have the same big memory leak this bug would be pointing at.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 14

18 years ago
Marking verified (invalid)
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.