Acrobat plugin process continues to run after all PDF documents are closed

RESOLVED DUPLICATE of bug 167165

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 167165
13 years ago
13 years ago

People

(Reporter: Warren Jones, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3 SUSE/1.0.3-0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3 SUSE/1.0.3-0.4

Firefox starts an "acroread" process to view a PDF document.  When the PDF
document is closed, the "acroread" process continues to run in the background.
When viewing large PDF documents, it can consume large amount of memory.  These
resources aren't released until Firefox exits or the user manually kills the
"acroread" process.

Reproducible: Always

Steps to Reproduce:
1. Open a PDF document in Firefox.
2. Close the PDF document.
3. Run "ps -C acroread -f"

Actual Results:  
The "ps" command shows acroread still running in the background.

Expected Results:  
acroread should be terminated when all PDF documents are closed.

Konqueror uses also uses the Acrobat plugin, and terminates the acroread
process when it's no longer needed.
it's an acrobat bug...

*** This bug has been marked as a duplicate of 167165 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.