In mozilla-1.7.7, right-click menu is always 90% screen height, 37 text items

RESOLVED INVALID

Status

RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: michael, Unassigned)

Tracking

({regression})

1.7 Branch
x86
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050417
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050417

The Mozilla browser versions I've used up through 1.7.6 have behaved properly,
with context-sensitive right-click menus.  After upgrading to 1.7.7, I've found
that the right-click menu is always about 90% of my screen height; if my mouse
pointer is more than about 10% above the bottom of the screen, the corresponding
top portion of the menu gets lost.  Also, the menu always has the same 37 text
entries (not counting separators), regardless of what kind of area I right-click on.

Reproducible: Always

Steps to Reproduce:
1.  Load any page
2.  Right-click anywhere within the page
3.

Actual Results:  
The menu is too long; this means, for example, that I can't right-click on a
link in the center of the screen and then click on "Copy Link Location".  I can
use the arrow keys to go up the proper number of slots (out of sight above the
top screen edge) and hit Return to effect the menu item behavior.

Expected Results:  
Display a context-sensitive menu that isn't so flaming long.  :^)

At somebody's suggestion, I renamed my .mozilla directory and restarted Mozilla.
 The right-click menu then behaved as it always has in previous versions.  While
this helps to isolate the problem (must be something 1.7.7 doesn't like about
one or more config files), it is hardly a workaround.  I need to eliminate the
1% cause of the problem, not the 99% useful files that *aren't* causing the problem.

Comment 1

14 years ago
Are there any errors in you JS Console (Tools->Web dev->)

> I need to eliminate the 1% cause of the problem, not the 99% useful files that 
> *aren't* causing the problem.

Unfortunately, yes.  You can
1. copy back files from your old profile into the clean one
or
2. backup your profile.  remove the files from your profile one-by-one until the
context menu works.
Keywords: regression
Version: unspecified → 1.7 Branch

Comment 2

14 years ago
*** Bug 293261 has been marked as a duplicate of this bug. ***
Michael, did you install any extensions in that profile?
(Reporter)

Comment 4

14 years ago
No, I had installed only themes at that point.

I should probably close this, since the Gentoo package maintainer released a
minor update on about April 27, and that fixed the problem.  Sorry, I've been
totally swamped at work the last couple weeks.  :^(
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 5

14 years ago
reopening - fixed is reserved for bug fixed-by-patches
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 6

14 years ago
resolving INVALID -- not a Mozilla bug.

please report problems in gentoo-built builds to gentoo... test with a
.mozilla.org build first before reporting to .mozilla.org
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.