Last Comment Bug 291515 - Implement "locked"/"hidden" as distribution defined list, not attribute on install.rdf
: Implement "locked"/"hidden" as distribution defined list, not attribute on in...
Status: VERIFIED INVALID
: dev-doc-complete
Product: Toolkit
Classification: Components
Component: Add-ons Manager (show other bugs)
: unspecified
: All All
: -- enhancement (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Andy McKay [:andym]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-22 14:03 PDT by Ben Goodger (use ben at mozilla dot org for email)
Modified: 2012-02-07 05:35 PST (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Ben Goodger (use ben at mozilla dot org for email) 2005-04-22 14:03:41 PDT
An item's lockedness/hiddenness should be defined by a list supplied by the
browser for its own internal items, rather than allowing items to specify it,
since even system level extensions may abuse locked/hidden.

e.g. I may always want to disable the Java integration items, even though it is
a system-level extension.

However, a browser redistributor that makes customizations in the form of an
extension, e.g. Netscape 9.0 may want to make their customizations be hidden
from the user... this second type is something that can easily be defined by the
distribution. 

We should have a list of IDs of items that are "locked"/"hidden" and have the
RDF datasource say "true" for the em:locked/hidden property only when asked for
these IDs.
Comment 1 Asa Dotzler [:asa] 2005-09-02 12:42:40 PDT
not making the boat, obviously.
Comment 2 Dave Townsend [:mossop] 2010-07-03 08:23:34 PDT
We no longer support the locked and hidden properties.
Comment 3 Henrik Skupin (:whimboo) 2010-07-04 18:44:45 PDT
Dave, for what we have used the locked properties?
Comment 4 Dave Townsend [:mossop] 2010-07-04 18:50:24 PDT
(In reply to comment #3)
> Dave, for what we have used the locked properties?

It meant the extension could not be uninstalled or disabled.
Comment 5 Henrik Skupin (:whimboo) 2010-07-18 14:49:53 PDT
Ok, so on bug 333012 comment 23 you have mentioned distribution bundles. How does it correlate with the proposal from this bug to implement it as a distribution defined list? This bug is not about the properties in the install.rdf file.
Comment 6 Robert Strong [:rstrong] (use needinfo to contact me) 2010-07-18 14:57:37 PDT
This bug is about implementing another way to lock / hide extensions in the same way as the locked / hidden attributes in the install.rdf file and the functionality to lock / hide extension manager extensions has been removed in part due to malicious / ill mannered extensions from doing this to users. Distribution bundles was implemented as part of the distribution system for custom browser distributions. I haven't personally tried them out so perhaps Dave or someone else can comment further about distribution bundles.
Comment 7 Dave Townsend [:mossop] 2010-07-19 10:21:35 PDT
You can include many extensions as distribution bundles which has the same effect of including the extension in the application with the old locked and hidden properties. So yes that is the alternative way to package these things now. It is something that is intended for system administrators wanting to packaged functionality with the browser.
Comment 8 Henrik Skupin (:whimboo) 2010-07-19 10:35:34 PDT
Dave, do you have an URL for me which points to the documentation of those distribution bundles? It's not BYOB, right?
Comment 10 Henrik Skupin (:whimboo) 2010-07-19 10:51:50 PDT
Thanks Benjamin! Using such a distribution bundle works perfect. The add-on is hidden and cannot be disabled or removed by the user.

I will call that verified invalid.
Comment 11 Mike Kaply [:mkaply] 2010-07-19 11:15:22 PDT
Henrik: Can you update that page with more info since you tested it?

In particular, do you put XPIs in that directory or do you put them unzipped with addon IDs as the directory names?
Comment 12 Henrik Skupin (:whimboo) 2010-07-19 11:22:31 PDT
I have simply copied the unzipped content under a subfolder with the extension id. That's all.

For updating the docs I would propose someone who knows all the underlying code. Let's put it a request in the keyword field.
Comment 13 Eric Shepherd [:sheppy] 2012-02-07 05:35:57 PST
Revised the text here:

https://developer.mozilla.org/en/extension_packaging#Including_add-ons_in_a_customized_application

Note You need to log in before you can comment on or make changes to this bug.