The firefox compilation fails if I use new cairo 0.4.0 dependency

RESOLVED WONTFIX

Status

()

Firefox
Build Config
RESOLVED WONTFIX
13 years ago
13 years ago

People

(Reporter: Zbigniew Luszpinski, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.7.7) Gecko/20050420
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.7.7) Gecko/20050420

If I compile firefox 1.0.3 with cairo 0.2.0 library it compiles well. But I use
now new 0.4.0 cairo library and firefox compilation fails. Could you update
firefox code to enable support for new cairo 0.4.0 library?

firefox 1.0.3 module has the following bug which breaks its compilation (when
cairo 0.4.0 is installed).

nsSVGCairoCanvas.cpp: In member function `nsresult
nsSVGCairoCanvas::Init(nsIRenderingContext*, nsIPresContext*, const nsRect&)
':
nsSVGCairoCanvas.cpp:121: error: `cairo_set_target_drawable' undeclared (first
use this function)
nsSVGCairoCanvas.cpp:121: error: (Each undeclared identifier is reported only
once for each function it appears in.)
make[6]: *** [nsSVGCairoCanvas.o] Error 1
make[6]: Leaving directory `/usr/src/mozilla/layout/svg/renderer/src/cairo'
make[5]: *** [libs] Error 2
make[5]: Leaving directory `/usr/src/mozilla/layout/svg/renderer/src'
make[4]: *** [libs] Error 2
make[4]: Leaving directory `/usr/src/mozilla/layout/svg/renderer'
make[3]: *** [libs] Error 2
make[3]: Leaving directory `/usr/src/mozilla/layout/svg'
make[2]: *** [libs] Error 2
make[2]: Leaving directory `/usr/src/mozilla/layout'
make[1]: *** [tier_9] Error 2
make[1]: Leaving directory `/usr/src/mozilla'
make: *** [default] Error 2
install: can not execute stat on `/usr/lib/firefox-1.0.3/icons/default.xpm': No
such file or directory

Reproducible: Always

Steps to Reproduce:
1. Remove cairo 0.2.0 library
2. Install cairo 0.4.0 library
3. Compile firefox

Actual Results:  
The compilation breaks with these errors:

nsSVGCairoCanvas.cpp: In member function `nsresult
nsSVGCairoCanvas::Init(nsIRenderingContext*, nsIPresContext*, const nsRect&)
':
nsSVGCairoCanvas.cpp:121: error: `cairo_set_target_drawable' undeclared (first
use this function)
nsSVGCairoCanvas.cpp:121: error: (Each undeclared identifier is reported only
once for each function it appears in.)
make[6]: *** [nsSVGCairoCanvas.o] Error 1
make[6]: Leaving directory `/usr/src/mozilla/layout/svg/renderer/src/cairo'
make[5]: *** [libs] Error 2
make[5]: Leaving directory `/usr/src/mozilla/layout/svg/renderer/src'
make[4]: *** [libs] Error 2
make[4]: Leaving directory `/usr/src/mozilla/layout/svg/renderer'
make[3]: *** [libs] Error 2
make[3]: Leaving directory `/usr/src/mozilla/layout/svg'
make[2]: *** [libs] Error 2
make[2]: Leaving directory `/usr/src/mozilla/layout'
make[1]: *** [tier_9] Error 2
make[1]: Leaving directory `/usr/src/mozilla'
make: *** [default] Error 2
install: can not execute stat on `/usr/lib/firefox-1.0.3/icons/default.xpm': No
such file or directory

Expected Results:  
Compilation should be finished without error.

Comment 1

13 years ago
This bug doesn't make sense. Firefox 1.0.3 doesn't have any Cairo code that I'm
aware of. On the trunk, we're using our own in-tree Cairo and updating it as
appropriate, since Cairo is not nearly stable enough to use as an external
(system) lib.

Comment 2

13 years ago
The aviary branch does contain some early development code for the cairo svg
renderer, and required a system installed cairo.  But as nobody should really be
using the svg support from the 1.0.x branch (a lot has happened for svg support
in the last year), I don't think we should spend the time updating that code for
the 0.4.0 api.  Cairo is currently undergoing some API rework, so even if this
was fixed it would be out of date again shortly.

-> WONTFIX
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.