Password Manager doesn't come up, unles you have stored a master password.

VERIFIED DUPLICATE of bug 28151

Status

()

Toolkit
Form Manager
P3
normal
VERIFIED DUPLICATE of bug 28151
18 years ago
10 years ago

People

(Reporter: esther, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Using today's builds 2000-02-24 on win98, mac and linux the Password Manager 
won't come up when clicking the button "View Stored Passwords".  Also, the 
"Display signons" dialog won't come up.  Tried mozilla and commercial builds.

1. Launch Browser
2. Select Preferences from the Edit menu
3. Select Password Manager listed under Advanced
4. Click on "View Stored Passwords".  

Expected: to get the Password Manager
Result: nothing happens  (Attaching the console.out file, which shows it was 
loaded and is there but nothing displays).

We (mailnews) needs this to work so a user can remove a mail server from the 
master password db.
(Reporter)

Comment 1

18 years ago
Just realized, with he profile I used to test this, I have not used the master 
password.  I went to another profile where I had entered a master password and 
this dialog does come up.  So the bug has changed to be the password manager 
won't come up unless you have stored a master password.   changing the 
description,  changing critical to major
Severity: critical → major
Summary: Password Manager doesn't come up. → Password Manager doesn't come up, unles you have stored a master password.

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M15
this seems like a dup of 28151.

*** This bug has been marked as a duplicate of 28151 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
verif.
Status: RESOLVED → VERIFIED

Comment 4

18 years ago
Things are getting confusing so let me straighten it up.  We currently have the 
following three bugs which relate to the case when no master password exists:

28151: change password gives an alert
29155: password-manager panel in prefs does not come up
29838: signon viewer does not come up

These are three distinct issues and we shouldn't be duping them.  I'm removing 
the dup indications.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Comment 5

18 years ago
Also downgrading it from major to normal.
Severity: major → normal
Status: REOPENED → ASSIGNED

Comment 6

18 years ago

*** This bug has been marked as a duplicate of 28151 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE
verif.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Assignee: morse → nobody
Component: Form Manager → Form Manager
Product: Core → Toolkit
QA Contact: bugzilla → form.manager
Target Milestone: M15 → ---
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.