Does not display Punjabi font for certain website

VERIFIED WORKSFORME

Status

()

Core
Layout: Text
VERIFIED WORKSFORME
13 years ago
7 years ago

People

(Reporter: paul_kainth, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Even after I install the intended font Firefox still displays some garbage but
IE works fine.

Reproducible: Always

Steps to Reproduce:
1.Visit the siteand install the font.
2.Visit the site again and you be prompted to install the font again
3.Click on the Canadian flag on the left, you'll see garbage

Actual Results:  
Install fonts page again.

Expected Results:  
Once the font is installed you should not see the install fonts page again. 
Once you click on the Canadian flag you should see writing in Punjabi.

Comment 1

13 years ago
Are you trying to display hindi or use an Indic script? If so, this is almost
certainly a known bug. Sorry.
the encoding is iso-8859-1 which isn't Punjabi

Tech Evan ?
(Reporter)

Comment 3

13 years ago
Acording to the website it's Punjabi Font.

Comment 4

13 years ago
(In reply to comment #3)
> Acording to the website it's Punjabi Font.

I am with Peter

% curl -I http://hamdardweekly.com/
HTTP/1.1 200 OK
Date: Thu, 28 Apr 2005 06:58:16 GMT
Server: Apache/2.0.48 (Linux/SuSE)
Last-Modified: Fri, 27 Feb 2004 21:44:59 GMT
ETag: "fa6fd-1c9-694f0cc0"
Accept-Ranges: bytes
Content-Length: 457
Content-Type: text/html; charset=ISO-8859-1

It is possible that you are using a 'fake' encoding with a font such
as DRChatrikWeb which matches. This is not going to work in compliant
browsers which have a correct way of achieving what you want. See
http://webtips.dan.info/char.html and various pages linked from there.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → EXPIRED
(Reporter)

Comment 7

13 years ago
Latest Version FireFox 1.0.7 problem still not fixed.
Status: RESOLVED → UNCONFIRMED
Resolution: EXPIRED → ---

Comment 8

13 years ago
Paul, 1.0 uses code that's not been touched since April of 2004. Please test in
1.5 beta 2 and see if this problem still exists.
http://www.mozilla.org/projects/firefox/
(Reporter)

Comment 9

13 years ago
Tried version 1.5 beta 2 and browser is still garbage but work with IE.

Comment 10

13 years ago
(In reply to comment #8)
> Paul, 1.0 uses code that's not been touched since April of 2004. Please test in
> 1.5 beta 2 and see if this problem still exists.
> http://www.mozilla.org/projects/firefox/

Adam, I was under the impression that Firefox was rendering the
pages on this site according to the headers and metadata sent.

If this is not a T.E. bug, then it may be a question of whether
the site was hoping to be renderered in a quirks mode, but had,
perhaps unwittingly, triggered standards compliant mode.

I would surprised if this report led to any improvement in Firefox,
and, of course, it may be a duplicate.
Assignee: bugs → nobody
(Reporter)

Comment 11

11 years ago
Verified even with version 2.0.0.3 bug is still there.
Component: OS Integration → Layout: Fonts and Text
Product: Firefox → Core
QA Contact: os.integration → layout.fonts-and-text

Comment 12

7 years ago
(In reply to paul_kainth from comment #11)
> Verified even with version 2.0.0.3 bug is still there.

I cannot reproduce with 3.6.24 but I might have such fonts installed on my system.
Paul, is this still an issue in Firefox 3.6 or 8.0 for you?
Summary: screen displays garbage → Does not display Punjabi font for certain website
The hamdardweekly.com site mentioned in the URL field is now serving its content in Unicode, and displays fine for me. (With no requirement to download a special font.)

The site was almost certainly relying on a custom-encoded (non-Unicode-compliant) font in the past, and Firefox did not support that. Now that the site's text is standards-based, it works as expected, and this report is no longer relevant.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago7 years ago
Resolution: --- → WORKSFORME
I collided with Jonathan saying much the same thing :)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.