If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Interface and RDF Resource names changed - fallout from bug 286034

RESOLVED FIXED

Status

()

Toolkit
Add-ons Manager
RESOLVED FIXED
13 years ago
9 years ago

People

(Reporter: rstrong, Assigned: rstrong)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050421 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050421 Firefox/1.0+

It appears that urn:mozilla:theme is no longer used for the default theme and
possibly elsewhere. A query of lxr returns 5 hits but I am unsure if any besides
the one in extensions.js needs to be fixed.
http://lxr.mozilla.org/seamonkey/search?string=urn%3Amozilla%3Atheme

Reproducible: Always

Steps to Reproduce:
Created attachment 181609 [details] [diff] [review]
patch
Assignee: bugs → moz_bugzilla
Status: NEW → ASSIGNED
Attachment #181609 - Flags: review?(bugs)
Created attachment 181610 [details] [diff] [review]
patch for consideration

The original patch is still fine but this one takes care additional fallout
from the checkin to bug 291572.

Besides the original issue it renames removeDownloadObserverAt to
removeDownloadListenerAt and addDownloadObserver to addDownloadListener in
extensions.js
It also changes urn:mozilla:extension:root to urn:mozilla:item:root in three
places in nsExtensionManager.js.in - this fixes the ability to move extensions
up, down, and to top in the EM.
Sorry, I meant checkin for bug 286034
Comment on attachment 181610 [details] [diff] [review]
patch for consideration

Ben - I suspect that with how new this code is and that since it is fallout
from bug 286034 that you would be the appropriate person to review.
Attachment #181610 - Flags: review?(bugs)
Changing the summary to be more descriptive of what the second patch covers
Keywords: regression
Summary: uninstalling selected theme fails - fallout from bug 286034 → Interface and RDF Resource names changed - fallout from bug 286034
Attachment #181609 - Attachment is obsolete: true
Attachment #181609 - Flags: review?(bugs)

Updated

13 years ago
Depends on: 286034

Updated

13 years ago
Blocks: 251100
Comment on attachment 181610 [details] [diff] [review]
patch for consideration

r=ben@mozilla.org
Attachment #181610 - Flags: review?(bugs)
Attachment #181610 - Flags: review+
Attachment #181610 - Flags: approval-aviary1.1a+
All but the following has been fixed as part of bug 291831
http://lxr.mozilla.org/seamonkey/source/toolkit/mozapps/extensions/content/extensions.js#910

-         
this.cmd_useTheme(document.getElementById("urn:mozilla:theme:{972ce4c6-7e08-4474-a285-3208198ce6fd}"));
+         
this.cmd_useTheme(document.getElementById("urn:mozilla:item:{972ce4c6-7e08-4474-a285-3208198ce6fd}"));

This will fail when uninstalling a theme that is in use.
Created attachment 181820 [details] [diff] [review]
patch

This is mainly a reference (hence no request for review) that includes the
remaining fix as well as fixes for several strict warnings along with cleanup
of the use of extensions.properties in the code.
Comment on attachment 181820 [details] [diff] [review]
patch

Ben - this includes the one liner that was overlooked in extensions.js along
with several strict warning fixes and general cleanup for consistency.
Attachment #181820 - Flags: review?(bugs)
Comment on attachment 181820 [details] [diff] [review]
patch

Me again - a one liner was missed in Ben's patch for bug 291831. Since there
were a few strict errors and some cleanup to do in the same file I put it all
in one patch... I will separate them if you prefer.
Attachment #181820 - Flags: review?(bugs) → review?(mconnor)
Comment on attachment 181820 [details] [diff] [review]
patch

I have a bunch of other fixes and I'm going to add the one liner etc. to that
patch.
Attachment #181820 - Attachment is obsolete: true
Attachment #181820 - Flags: review?(mconnor)
Resolving fixed - the one remaining issue not fixed in bug 291831 will be fixed
by the patch in bug 291946.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.