Closed Bug 291609 Opened 17 years ago Closed 14 years ago

Unable to " Print Selection Only " from message body, even when right-click|Edit as New, which prints blank page

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 66806

People

(Reporter: ckrainey, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

In Thunderbird 1.0.2, I am unable to select " Print Selection Only" from the
Thunderbird Print menu ... it is greyed-out(unavailable).  Using a techniques
observed in the Thunderbird forums:  righ-click|Edit as New only prints a blank
page.

Reproducible: Always

Steps to Reproduce:
1.  Double-click to open message
2.  mouse-select some text in body
3.  click File|Print|Thunderbird and attempt to select " Print Selection Only"

Actual Results:  
Unable to complete steps, above.  Only way to activate the " Print Selection
Only " check-box is to right-click message body|Edit as New and then " Print
Selection Only " is available, BUT ... it prints a blank page even though text
is still highlighted.

Expected Results:  
" Print Selection Only " is an important tool for the concise extraction of text
from long-winded diatribes.  This should always be available.
Summary: Unable to " Print Selection Only " from message body, even when right-click|edit as new, which prints blank page → Unable to " Print Selection Only " from message body, even when right-click|Edit as New, which prints blank page
Confirm.

version 1.0.2 (20050403)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Dupe of bug 66806...
Component: General → Mail Window Front End
OS: MacOS X → All
Hardware: Macintosh → All
Version: unspecified → Trunk
*** Bug 326539 has been marked as a duplicate of this bug. ***
*** Bug 284631 has been marked as a duplicate of this bug. ***
Re: Adam Macznik   Comment #2

"Dupe of bug 66806..."

Isn't that listed for Mozilla Suite (?no longer supported?) whereas this is for Thunderbird? However, since the problem applies to TB (and not to FF, by the way), which is very active and high profile, shouldn't those votes be applied (?also?) to this bug? Alternatively, could that bug could be reassigned to Thunderbird?
(In reply to comment #5)
> Re: Adam Macznik   Comment #2
> > "Dupe of bug 66806..."
> Isn't that listed for Mozilla Suite 

yes

>(?no longer supported?) 

no. it is just supported by a different group of people

> Thunderbird? However, since the problem applies to TB (and not to FF, by the
> way), which is very active and high profile, shouldn't those votes be applied
> (?also?) to this bug? Alternatively, could that bug could be reassigned to
> Thunderbird?

I can't speak specifically to thunderbird, but having followed printing bugs somewhat for the past year I think it unlikely to see this until the core print engine is rewritten - something I doubt you will see in any bug comments.  I don't have any good references, but iirc the leading idea, one that makes sense to me, is for print selection for the UI to come through a new, better print preview. 

see also http://wiki.mozilla.org/Firefox/Feature_Brainstorming:Printing#Selective_printing
QA Contact: front-end
Thunderbird needs to add this Feature.
You have 81 people wanting this in Firefox in this bug:
Bug 204519 – Add Print option to main context menu

and a similar Mozilla bug here with 8 more:
Bug 137014 – add "Print Frame" to frame flyout of browser context menu 
Can confirm it in TB 2.0.0.4. The workaround with "edit as new" works, but it's a shame that this can't be done.
Duplicate of this bug: 388448
It's very disappointing to see that this bug in TB has been present since prior to first report on 2005-04-23 and has not been fixed yet, despite multiple bug reports since then.  In long e-mail discourses, the ability to select only the most recent portion of the e-mail and print it is extremely important.
(In reply to comment #11)
> It's very disappointing to see that this bug in TB has been present since prior
> to first report on 2005-04-23 and has not been fixed yet, despite multiple bug
> reports since then.  In long e-mail discourses, the ability to select only the
> most recent portion of the e-mail and print it is extremely important.
> 
Agreed but why are there only ten votes for it? If you had voted there would have been 11. If every interested party had voted there could have been hundreds. Please - always vote, whether or not you think it appropriate to post as well.

Sorry about the noise. Reason obvious.
How and where do I vote to get it moved up the list?  My wife is driving me crazy. I'd help if I could or should say, knew how.
At the top of this page, when logged in, you should see:
Votes:  	XX (show)  (vote)
Click the (vote) link. Then check this bug and submit.
(In reply to comment #14)
> At the top of this page, when logged in, you should see:
> Votes:          XX (show)  (vote)
> Click the (vote) link. Then tick/check this bug and submit.
> 
and don't forget to click "Change my votes" button at the bottom of that page or it won't record your vote.
Love thunerbird but this is really annoying. Seems to be taking a long time to solve a problem that doesnt occur in other mail programmes!
I'm also getting grief from my wife over this bug. This should be a simple fix; enabling the "Selection" member for the printer dialog. Help, please!
I reported this problem more than 6 months ago, and others agree with me,  it's ridiculous that it has not been fixed yet!!!  In this time where awareness of the environment is on the increase this PAPER WASTER shoud be dealt with!
I don't understand it: This is a function which every notepad clone should have, but nobody take a look at this! So many users are laughing at TB - this is so embarrassing...
Folks, this is a bug-reporting site, not LiveJournal. If you want to express your desire for this bug to be resolved, please vote for it, per the instructions in Comment #15.

If your comment doesn't include any new information about the nature of the bug, then please avoid commenting--you're just adding more noise to the thread. The time spent by developers reading these comments could instead be spent on fixing the bug!
Flags: blocking-thunderbird3?
This bug still exists in the current Release Candidate of Firefox 3. Why can this error not be marked as critical?
(In reply to comment #21)
> This bug still exists in the current Release Candidate of Firefox 3. Why can
> this error not be marked as critical?

This bug is about Thunderbird and not Firefox 3.
Assignee: mscott → nobody
Flags: wanted-thunderbird3+
Flags: blocking-thunderbird3?
Flags: blocking-thunderbird3-
Retriaging according to new policy for flags.  

https://wiki.mozilla.org/Thunderbird:Release_Driving

(bugs marked wanted- don't indicate we wouldn't accept patches, but that they're not going to be the focus for release drivers)

(we're short of printing experts =( )
Flags: wanted-thunderbird3+ → wanted-thunderbird3-
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 66806
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.