Display order for authors of the same addon cannot be specified

VERIFIED FIXED in 3.5

Status

enhancement
VERIFIED FIXED
14 years ago
4 years ago

People

(Reporter: mao, Assigned: fligtar)

Tracking

Dependency tree / graph

Details

()

Multiple developers of the same addon should have the power to specify the order
which their names are listed with on AMO pages. This order may represent the 
relevances of the different contributions, may descend from a commercial
agreement or may be dictated by other reasons, but anyway the current
pseudo-randomness - which merely reflects the UserProfile table insert order -
is hardly acceptable in most situations.
The effort to do this is probably more than its worth.  We'd have to add another
column to the DB and completely redo the GUI for adding authors.
Severity: normal → enhancement
Target Milestone: 1.0 → ---
AMO bugspam. Correcting QA contacts on OLD bugs (mozilla.update@update.bugs)

-> Correct QA contact (developers@add-ons.bugs)

Filtermeplzkthx
QA Contact: mozilla.update → developers
Depends on: remora-dev
Assignee: g.maone → fligtar
Target Milestone: --- → 3.0
Target Milestone: 3.0 → 3.1
Duplicate of this bug: 375057
Assignee: fligtar → nobody
Assignee: nobody → fligtar
Target Milestone: 3.1 → 3.5
Blocks: 428217
No longer depends on: remora-dev
This has been fixed in AMO 3.5.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.