Firefox 1.0.3 w/ Latest User-agent switcher is unusable

RESOLVED INVALID

Status

()

Firefox
General
--
critical
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Yegor, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: 1.0.3 Auto-update with the latest User-agent switcher update (firefox starts but unusable)

This happened on both my computers, one running WinXP SP2, the other Debian 
Linux (ver. 1:3.3.5-2) Gnome (ver. 2.2).

After automatic update of firefox to version 1.0.3 and the latest user-agent 
switcher (don't remember the version) the browser became totally unusable. See 
the screen shot at:
http://www.spicesoft.com/img/bug_win_xp_sp2.JPG

On the screen shot I demonstrate the behaviour when I try to drop down the 
locations list. The menu (File, Edit, View, Go, etc) is not responding. I 
can't type the location. Automatic update is working, saying that no new 
updates are available which is natural since I have just updated everything. 
Search-engine list shows up at the same place (top-left corner).

Similar bugs could be 216288 or 267798 but in my case firefox does NOT crash 
or exit, it just behaves like an idiot. Rebooting did not help. My guess: the 
agent-switcher is to blame.

Thanks.

Reproducible: Always

Steps to Reproduce:
1. Do the complete update to 1.0.3 together with agent-switcher (WinXP SP2, 
Debian)
2. Start (or restart) firefox

Actual Results:  
Firefox became unusable in the sense explained above

Expected Results:  
Act like a web-browser

Sorry, can't do anything with my firefox right now.
Does it work if you disable the useragent switcher ?
(run "firefox -safe-mode")
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Does it work if you disable the useragent switcher ?
> (run "firefox -safe-mode")
> 
Safe-mode did not help as the menu is not responding. To make firefox work again
I did these steps:
1. Shut down firefox
2. Moved personal firefox settings directory
"C:/Documents and Settings/%username%/Application Data/Mozilla/Firefox"
to another location.
3. Started Firefox so that it created the same directory again.
4. Shut down firefox again
5. Overwrote files (without directories) in the
.../Profiles/abrakadabra.default/*.*
with the old files
6. Restarted Firefox.
7. Now it is working. User-agent switcher is off. Maybe something else is also
off :)

Update button disappeared. There was also some kind of "Theme" or something
which came with the latest update. It is probably also gone.

Thanks.
"Safe-mode did not help as the menu is not responding" 
Safemode is a startup swicth and nothin in the menu.
Or Do you mean that you closed FF and tried to run it in the safemode and the
menu still hung ?

anyways, this works with a clean profile and teh UA swicther seems to be the
problem -> invalid (broken extension)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> "Safe-mode did not help as the menu is not responding" 
> Safemode is a startup swicth and nothin in the menu.
> Or Do you mean that you closed FF and tried to run it in the safemode and the
> menu still hung ?
Yap, that is what I meant. Actually safe mode behaved exactly as normal mode,
i.e. irresponsive menu, no bookmarks bar, drop-down lists (locations and search
engines appear in the top-left corner). It also seemed like firefox actually
loads pages (according to rising CPU usage and disk activity) and you can
blindly type page location and search criteria, but all text boxes, including
the page panel, appear empty, just like on the screen-shot. Maybe the problem is
caused by an error when loading configuration files, so firefox uses
uninitialized variables.

> 
> anyways, this works with a clean profile and teh UA swicther seems to be the
> problem -> invalid (broken extension)
You need to log in before you can comment on or make changes to this bug.