Closed Bug 291711 Opened 16 years ago Closed 16 years ago

Cursor not updating over link when using mouse scroll

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 50511

People

(Reporter: richardvallee, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.7) Gecko/20050414 Firefox/1.0.3 StumbleUpon/1.9993
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.7) Gecko/20050414 Firefox/1.0.3 StumbleUpon/1.9993

When using the scroll wheel on a mouse to navigate a site, the cursor will not
update to its "over link" status when it is located over a link following the
scroll. Moving the cursor will update it however.

Reproducible: Always

Steps to Reproduce:
1. Place your mouse cursor on a spot where it will hit a <a> link by scrolling
with the mouse.
2. After the scroll, as the cursor is over the link, it will keep its "select
arrow" status rather than the link hand.
3. Move the cursor to any degree and it will update to its correct hand cursor.

Actual Results:  
The cursor was at first incorrect, displaying the select arrow, and was
correctly updated by moving it minimally.

Expected Results:  
Update the cursor to its "hand over link" status as soon as the cursor is
located over a link as a result of the scroll, without having to move the cursor.

*** This bug has been marked as a duplicate of 50511 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.