If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox displays popup window when loggin in at the web-site

RESOLVED DUPLICATE of bug 243572

Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 243572
13 years ago
13 years ago

People

(Reporter: Sean Grisham, Assigned: Blake Ross)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050419 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050419 Firefox/1.0.4

When I'm accessing the web-site which requires the username/password and I
specify them within the URL (like http://seangrisham:pass@www.test-site.com),
the firefox displays the popup window:
You are about to login to the site "www.test-site.com" with the username
"seangrisham". 

I've been told there's no setting to change this behaviour and I'd like to file
this feature request to make a setting for this popup window not to show up.

Reproducible: Always

Steps to Reproduce:
1. Sorry I don't have an open test web-server I can provide you with the login
for, but try accessing an URL like: http://seangrisham:pass@www.test-site.com

Actual Results:  
A popup window You are about to login to the site "www.test-site.com" with the
username "seangrisham" comes up.


Expected Results:  
I'd like to have a setting in preferences to get rid of the Firefox popup window.
You can effectively disable this by using about:config to set
network.http.phishy-userpass-length to a number larger than any user name you
use to login.

See bug 243572 comment 3 and bug 276018 comment 2.

*** This bug has been marked as a duplicate of 243572 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.