Crash: "onBlur=close()"

VERIFIED DUPLICATE of bug 28988

Status

()

P3
normal
VERIFIED DUPLICATE of bug 28988
19 years ago
10 years ago

People

(Reporter: vince.webb, Assigned: joki)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Mozilla M13

onMouseover=window.open(url,name,features)
opens not one window but lots of them and then it crashes

Comment 1

19 years ago
In 2000022508 works fine.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

19 years ago
I tried the test page
http://www.vincew.demon.co.uk/mozilla/mouseover/
with 2000022808. It no longer opens lots of windows
as it did using M13 but it still crashes.

The child window contains <BODY onBlur=close()>
On Netscape 4 the child window is given focus as
soon as it opens. Focusing on anything other than the child
e.g. the main window closes the child window.

With Mozilla 2000022808 the onBlur=close() does not operate.
Moving focus from child to main to child crashes mozilla.

Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 3

19 years ago
Moving focus from child to main to child to main crashes mozilla.

Comment 4

19 years ago
Ok, can reproduce.  Moving to javascript engine, I am assuming this is javascript.
Assignee: cbegle → rogerl
Component: Browser-General → Javascript Engine
QA Contact: asadotzler → rginda
(Reporter)

Comment 5

19 years ago
Created attachment 6117 [details]
onBlur=close() and crash
(Reporter)

Comment 6

19 years ago
The original test page for this bug 29175 was aimed at an
onMousever problem that has been fixed since M13.
The remaining issue shown up by that test page
"onBlur=close()"
can be seen with a very much more simple test, attached 4 Mar 2000

Comment 7

19 years ago
Confirming and changing summary to reflect the onblur part.  Seeing this crash
on m15 nightly 2000030408
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: onMouseover go ape → Crash: "onBlur=close()"

Comment 8

19 years ago
On build from 3/6, works fine.
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Component: Javascript Engine → DOM Level 0
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

19 years ago
I have tried with 2000030613 there is no change.
The onBlur=close() does not close the window when expected.
After switching focus to and fro a couple of times the
window closes and mozilla crashes.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 10

19 years ago
Urg, sure enough, Sorry. Though I'm certain i got the attachment to work on 3/6.

Here's the stack trace:
nsVoidArray::Count() line 43 + 3 bytes
nsEventListenerManager::HandleEvent(nsIPresContext * 0x031ab0d0, nsEvent * 
0x0012f724, nsIDOMEvent * * 0x0012f568, unsigned int 0x00000002, nsEventStatus * 
0x0012f744) line 1065 + 33 bytes
GlobalWindowImpl::HandleDOMEvent(GlobalWindowImpl * const 0x02cfeac4, 
nsIPresContext * 0x031ab0d0, nsEvent * 0x0012f724, nsIDOMEvent * * 0x0012f568, 
unsigned int 0x00000002, nsEventStatus * 0x0012f744) line 374
nsDocument::HandleDOMEvent(nsDocument * const 0x02e290a0, nsIPresContext * 
0x031ab0d0, nsEvent * 0x0012f724, nsIDOMEvent * * 0x0012f568, unsigned int 
0x00000001, nsEventStatus * 0x0012f744) line 2482
nsEventStateManager::PreHandleEvent(nsEventStateManager * const 0x03174030, 
nsIPresContext * 0x031ab0d0, nsGUIEvent * 0x0012fa50, nsIFrame * 0x025d53a0, 
nsEventStatus * 0x0012f9b8, nsIView * 0x0317f390) line 655
PresShell::HandleEvent(PresShell * const 0x0315f5b4, nsIView * 0x0317f390, 
nsGUIEvent * 0x0012fa50, nsEventStatus * 0x0012f9b8) line 3026 + 43 bytes
nsView::HandleEvent(nsView * const 0x0317f390, nsGUIEvent * 0x0012fa50, unsigned 
int 0x00000008, nsEventStatus * 0x0012f9b8, int & 0x00000000) line 799
nsView::HandleEvent(nsView * const 0x03177a60, nsGUIEvent * 0x0012fa50, unsigned 
int 0x00000008, nsEventStatus * 0x0012f9b8, int & 0x00000000) line 784
nsView::HandleEvent(nsView * const 0x0315d0a0, nsGUIEvent * 0x0012fa50, unsigned 
int 0x0000001c, nsEventStatus * 0x0012f9b8, int & 0x00000000) line 784
nsViewManager2::DispatchEvent(nsViewManager2 * const 0x0315d320, nsGUIEvent * 
0x0012fa50, nsEventStatus * 0x0012f9b8) line 1216
HandleEvent(nsGUIEvent * 0x0012fa50) line 69
nsWindow::DispatchEvent(nsWindow * const 0x03177934, nsGUIEvent * 0x0012fa50, 
nsEventStatus & nsEventStatus_eIgnore) line 493 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012fa50) line 514
nsWindow::DispatchFocus(unsigned int 0x0000006b) line 3103 + 15 bytes
nsWindow::ProcessMessage(unsigned int 0x00000008, unsigned int 0x00000000, long 
0x00000000, long * 0x0012fcb4) line 2343 + 19 bytes
nsWindow::WindowProc(HWND__ * 0x03410158, unsigned int 0x00000008, unsigned int 
0x00000000, long 0x00000000) line 671 + 27 bytes
USER32! 77e719d0()
USER32! 77e71982()
NTDLL! 77f763a3()
USER32! 77e71bd8()
nsAppShell::Run(nsAppShell * const 0x0143c550) line 96 + 24 bytes
nsAppShellService::Run(nsAppShellService * const 0x0143be50) line 393
main1(int 0x00000001, char * * 0x010a4a10, nsISplashScreen * 0x00000000) line 
769 + 32 bytes
main(int 0x00000001, char * * 0x010a4a10) line 889 + 17 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77f1b
Assignee: rogerl → joki
Status: REOPENED → NEW
Component: DOM Level 0 → Event Handling
QA Contact: rginda → janc
(Assignee)

Comment 11

19 years ago
This is a dupe of a generic problem of closing windows from event handlers.  The 
bug I'm duping it on using onsubmit but the issue is the same.

*** This bug has been marked as a duplicate of 28988 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → DUPLICATE

Updated

19 years ago
Keywords: verifyme

Comment 12

19 years ago
verified duplicate
Status: RESOLVED → VERIFIED

Updated

10 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.