{inc}If auto width table has list element that is child of font element, layout is reflowed.

RESOLVED FIXED

Status

()

Core
Layout: Block and Inline
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: masayuki, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [reflow-refactor], URL)

See testcase.
http://bugzilla.mozilla.gr.jp/attachment.cgi?id=2734&action=view

In this case, the elements are follwing relation.

table(auto width)
  font
    ul
      li
        a[href]

If the link is clicked, the layout reflow.(layout is broken)
If the list element is p element, I cannot reproduce it.

In DOM Inspector, I can see same relation.
font
  ul
    li

But if ul>li elements are p elelemnt, I can see follwing relation.
font
p
  font

Comment 1

13 years ago
Could you attach a screen shot of what you think is the bug? I think it is just
the <br clear=all> that makes the extra space, after all, it is a line break.
(In reply to comment #1)
> Could you attach a screen shot of what you think is the bug? I think it is just
> the <br clear=all> that makes the extra space, after all, it is a line break.

Did you say for bug 291759?
Oops...

bug 291759 -> bug 291757
It is reproduced on WinXP and Linux.
OS: Windows XP → All

Comment 5

13 years ago
Yes, sorry about that.
OS: All → Windows XP

Updated

13 years ago
OS: Windows XP → All
Hardware: PC → All

Updated

13 years ago
Blocks: 261196
Bernd:

This bug is reproduced in table cell only.
Please check it.

Comment 7

13 years ago
>This bug is reproduced in table cell only. Please check it.
I am little bit puzzled, what should I do? Yes I see that too.
So usually when things shrink in a auto table thats a result of a wrong
maximumwidth of the content during incr. reflow. This can be debugged with
reflow log http://www.mozilla.org/newlayout/doc/frame_reflow_debug.html . Have 
a look for the m = numbers. I think it comes from the margins on the list
element. Bug 103582 looks very similiar. Bug 195770 see my comments there why
one should produce and analyze a reflow log.

Comment 8

13 years ago
Bernd, I think that this problem has same cause as Bug 147558, since posted
attachment 165805 [details] [diff] [review] also has an effect for testcase.

Comment 9

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050428
Firefox/1.0+

I can still reproduce this.
Depends on: 147558
Summary: If auto width table has list element that is child of font element, layout is reflowed. → {inc}If auto width table has list element that is child of font element, layout is reflowed.
Whiteboard: [reflow-refactor]
I cannot reproduce on 6/20 build.
Thank you, Saito-san!
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.