dropping XPI in extensions/ does not install it

RESOLVED DUPLICATE of bug 291666

Status

()

RESOLVED DUPLICATE of bug 291666
14 years ago
11 years ago

People

(Reporter: asqueella, Assigned: bugs)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Dropping XPI in extensions/ does not install it. Instead I see these messages in
JS Console, and the extension is stuck in the EM (with "This item will be
installed ...").

Install Location returned an item path that does not exist! Item Path:
C:\Documents and Settings\Коля\Application
Data\Mozilla\Firefox\Profiles\p763f7tq.em-test\extensions\{3f0da09b-c1ab-40c5-8d7f-53f475ac3fe8},
Location Key: app-profile Item ID: {3f0da09b-c1ab-40c5-8d7f-53f475ac3fe8}


safeInstallOperation: install operation (caller-supplied callback) failed,
rolling back file moves and aborting installation.


ExtensionManager:_finishOperations - failure, catching exception...
[Exception... "Component returned failure code: 0x80520015
(NS_ERROR_FILE_ACCESS_DENIED) [nsIZipReader.extract]"  nsresult: "0x80520015
(NS_ERROR_FILE_ACCESS_DENIED)"  location: "JS frame ::
file:///C:/PROGRA~1/Mozilla.org/FIREFO~1.EM/components/nsExtensionManager.js ::
extractExtensionFiles :: line 1190"  data: no]

Comment 1

14 years ago
Is this similar to what bug 291666 comment 11 says? 
(Reporter)

Comment 2

14 years ago
I doubt that, as the same XPI installs fine through drag and drop. We'll see
when that one gets fixed.

http://www.mozilla.org/projects/firefox/extensions/em-changes.html says it
should work, asking for blocking1.1.
(Reporter)

Comment 3

14 years ago
try again...
Flags: blocking-aviary1.1?

Comment 4

14 years ago
This might be an encoding issue... what is your username (C:\Documents and
Settings\...)? Can you try the same thing with an ASCII username (Or a profile
on an ASCII path)?
QA Contact: bugs → benjamin
(Reporter)

Comment 5

14 years ago
No I just tested it for profile located at c:\temp and it didn't work either.
This doesn't work with global installations too.
(Reporter)

Comment 6

14 years ago
Hmm, I tried installing via drag-and-drop to extension manager, and it didn't
work either. Looks like it's general "can't install extensions" issue. Others
(on forums) are seeing this as well.
I believe this is a dupe of bug 291666... I am able to install by dropping an
XPI in the extensions directory with the patch from that bug and I am not able
to without it.
(Reporter)

Comment 8

14 years ago
JS Console error is different though. I'll dupe this, if needed, after that
patch lands.
(In reply to comment #8)
> JS Console error is different though. I'll dupe this, if needed, after that
> patch lands.
Yeah, I grabbed the wrong js console error when I made that comment. The one you
have here is one of the js console messages from that bug and also include the
will be installed message in the EM.
(Reporter)

Comment 10

14 years ago
okay, dupe it then.
Flags: blocking-aviary1.1?
I'm not dupe happy :) just trying to keep track of what's going on to avoid
duplicate work and it appears this will be fixed by bug 291846. Marking depends
on bug 291846
Depends on: 291846
Make that bug bug 291666 :)
Depends on: 291666
No longer depends on: 291846
(Reporter)

Comment 13

14 years ago
You were right. The patch fixes the problem for me. Thanks Robert.

*** This bug has been marked as a duplicate of 291666 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
No longer depends on: 291666
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.