repeated corrupt downloads since about 4-14-2005

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: allltaken, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050408
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050408

I have had only one good download of a Mozilla nightly full installer since
about 4-14. I've tried downloading often using the 4-11 nightly, then tried an
earlier nightly to see if the 4-11 build had problems downloading. Yesterday and
today I got bad downloads using the 4-08-2005 nightly. The only executable one
was the 4-21 nightly from the Oregon mirror. It gave me a downloading error too.

Two problems occur in apparently complete downloads. The first and most common
is that or more modules (browser.xpi, etc) is reported defective when I run the
installer. If the file is good, the verification is quick, but if it's
defective, the verification seems to take quite a bit longer (to determine the
location of the errors?), and then bad modules are reported.

A couple of times the response (running the installer in a dos window as usual)
"Program too big to fit in memory." In this case, no installer window opens,
just a console error message.

Sometimes downloads are reported complete but aren't, but that's another bug. I
think running the installer incomplete also results in xpi modules or the gecko
zip being reported defective.



Reproducible: Sometimes

Steps to Reproduce:
1. Navigate to a main or mirror site to download a copy of Mozilla Win32 full
installer
2. Download it (via http or ftp, doesn't seem to matter)
3. Execute it.

Actual Results:  
One of the two types of error occurs as described above.


Expected Results:  
The installer should have verified the download to be correct and proceeded with
the installation steps on having a good download. The high frequency of bad
downloads indicates that something is wrong with the files, data transmission or
downloading code. 

I downloaded a nightly at least once using MSIE6, also with the type of errors
reported. So the problem probably is not with the Mozilla downloading code. My
system runs an extensive memory check on booting up, so it's probably not
suffering from memory cells going bad either. Other (shorter) files like the
gecko sdk zipfile were downloaded correctly.

If this is the ONLY bug report of this sort, I would wonder why I can download
other files correctly and can't do Mozilla nightlies.

I've used Mozilla to download later versions of itself for 2-3 years, and it
would be a major regression to have repeated download failures now.
(Reporter)

Comment 1

14 years ago
After one or two bad downloads today, I got two good ones using Mozilla/5.0
(Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050408. Will try the downloading
function of today's nightly tomorrow.
(Reporter)

Comment 2

14 years ago
Yesterday's downloads proved today to be bad, after uninstalling an older
nightly and trying to run yesterday's nightly installer and the 1.7.7 installer.
I started the installers yesterday to see whether they indicated the downloads
were good or not. They evidently looked at files for the existing installation
instead of data from the new installer files, and falsely reported that the
downloads were good. They were not.

So I've still only had one good download since 4-11. What's wrong?
(Reporter)

Comment 3

14 years ago
Why might file size be a factor in download failures? I'm using (Windows; U;
Win98; en-US; rv:1.8b2) Gecko/20050408 today.

This file I just downloaded from the main Mozilla server had no reported errors:
GECKO-~1 ZIP     1,249,191  04-26-05 11:05a gecko-sdk-i586-pc-msvc.zip

Here's a list of errors in the MOZILL~1 ZIP    11,459,251  04-26-05 11:59a
mozilla-i586-pc-msvc.zip I just downloaded and tested with pkunzip.


---------- mozmsvc.txt
[14]Testing: mozilla/chrome/chatzilla.jar  PKUNZIP: (W21) Warning! file has bad
table
[15]PKUNZIP: (W15) Warning! file fails CRC check
[16]PKUNZIP: (W13) Warning! inconsistent local header for file:
mozilla/chrome/chrome.rdf
[17]Testing: mozilla/chrome/chrome.rdf  PKUNZIP: (W21) Warning! file has bad table
[18]PKUNZIP: (W15) Warning! file fails CRC check
[19]PKUNZIP: (W13) Warning! inconsistent local header for file:
mozilla/chrome/chromelist.txt
[20]Testing: mozilla/chrome/chromelist.txt  PKUNZIP: (W21) Warning! file has bad
table
[21]PKUNZIP: (W15) Warning! file fails CRC check
[22]PKUNZIP: (W13) Warning! inconsistent local header for file:
mozilla/chrome/classic.jar
[23]Testing: mozilla/chrome/classic.jar  PKUNZIP: (W15) Warning! file fails CRC
check
[24]Testing: mozilla/chrome/comm.jar  PKUNZIP: (W21) Warning! file has bad table
[25]PKUNZIP: (W15) Warning! file fails CRC check
[61]Testing: mozilla/chrome/modern.jar  PKUNZIP: (W21) Warning! file has bad table
[62]PKUNZIP: (W15) Warning! file fails CRC check
[63]PKUNZIP: (W13) Warning! inconsistent local header for file:
mozilla/chrome/overlays.rdf
[64]Testing: mozilla/chrome/overlays.rdf  PKUNZIP: (W23) Warning! file has bad table
[65]PKUNZIP: (W15) Warning! file fails CRC check
[66]PKUNZIP: (W13) Warning! inconsistent local header for file:
mozilla/chrome/pipnss.jar
[67]Testing: mozilla/chrome/pipnss.jar  PKUNZIP: (W23) Warning! file has bad table
[68]PKUNZIP: (W15) Warning! file fails CRC check
[69]PKUNZIP: (W13) Warning! inconsistent local header for file:
mozilla/chrome/pippki.jar
[70]Testing: mozilla/chrome/pippki.jar  PKUNZIP: (W15) Warning! file fails CRC check
[71]PKUNZIP: (W13) Warning! inconsistent local header for file:
mozilla/chrome/sroaming.jar
[72]Testing: mozilla/chrome/sroaming.jar  PKUNZIP: (W15) Warning! file fails CRC
check
[73]PKUNZIP: (W13) Warning! inconsistent local header for file:
mozilla/chrome/stylesheets.rdf
[74]Testing: mozilla/chrome/stylesheets.rdf  PKUNZIP: (W23) Warning! file has
bad table
[75]PKUNZIP: (W15) Warning! file fails CRC check
[76]PKUNZIP: (W13) Warning! inconsistent local header for file:
mozilla/chrome/tasks.jar
[77]Testing: mozilla/chrome/tasks.jar  PKUNZIP: (W23) Warning! file has bad table
[78]PKUNZIP: (W15) Warning! file fails CRC check
[79]PKUNZIP: (W13) Warning! inconsistent local header for file:
mozilla/chrome/toolkit.jar
[80]Testing: mozilla/chrome/toolkit.jar  PKUNZIP: (W15) Warning! file fails CRC
check
[82]Testing: mozilla/chrome/venkman.jar  PKUNZIP: (W21) Warning! file has bad table
[83]PKUNZIP: (W15) Warning! file fails CRC check
[84]PKUNZIP: (W13) Warning! inconsistent local header for file:
mozilla/components/accessibility-msaa.xpt
[85]Testing: mozilla/components/accessibility-msaa.xpt  PKUNZIP: (W23) Warning!
file has bad table
[86]PKUNZIP: (W15) Warning! file fails CRC check
[87]PKUNZIP: (W13) Warning! inconsistent local header for file:
mozilla/components/accessibility.dll
[88]Testing: mozilla/components/accessibility.dll  PKUNZIP: (W15) Warning! file
fails CRC check
[89]PKUNZIP: (W13) Warning! inconsistent local header for file:
mozilla/components/accessibility.xpt
[90]Testing: mozilla/components/accessibility.xpt  PKUNZIP: (W21) Warning! file
has bad table
[91]PKUNZIP: (W15) Warning! file fails CRC check
[92]PKUNZIP: (W13) Warning! inconsistent local header for file:
mozilla/components/addrbook.dll
[93]Testing: mozilla/components/addrbook.dll  PKUNZIP: (W15) Warning! file fails
CRC check
[154]Testing: mozilla/components/gklayout.dll  PKUNZIP: (W21) Warning! file has
bad table
[155]PKUNZIP: (W15) Warning! file fails CRC check
[157]Testing: mozilla/components/gkplugin.dll  PKUNZIP: (W15) Warning! file
fails CRC check
[749]PKUNZIP: (W26) Warning! mozilla-i586-pc-msvc.zip has errors!
(Reporter)

Comment 4

14 years ago
The recent bad downloads reported here may be due to an obscure hardware problem
with my secondary disk drive, which held my download directory. I got a good
full-installer download today (running now) stored on the primary disk. After
copying it to the secondary and trying a file-compare, I got some errors. Just
now, I'm finding that the installer program running off the secondary drive gave
an out-of-memory error message, while the program running from the primary
verified OK now.

For now, the bad downloads appear due to a recent and subtle hardware problem.
(Reporter)

Comment 5

14 years ago
Execreble disk drive & lack of error detection...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.