Closed Bug 291830 Opened 15 years ago Closed 15 years ago

Pane selection icons jump and dance 1px horizontally on Mac

Categories

(Firefox :: Preferences, defect, trivial)

PowerPC
macOS
defect
Not set
trivial

Tracking

()

RESOLVED FIXED
Firefox1.5

People

(Reporter: mark, Assigned: mark)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050423 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050423 Firefox/1.0+

The pane selection radio icons (General, Privacy, etc.) jump to the left and
right depending on which pane is selected.  The selected icon and all icons to
the right of it are bumped 1px to the right.  When the selection is changed, the
icons jump accordingly.

Reproducible: Always

Steps to Reproduce:
Firefox:Preferences..., click the General icon.

Click Content.  Observed result: the General and Privacy icons moved one pixel
to the left.  Expected result: the icons should have stayed in place.

Click Privacy.  Observed result: the Privacy icon moves one pixel to the right.
 Expected result: the icon should not have exhibited symptoms of ADD.

Repeat ad nauseam.  Then apply the simple patch.



This bug only occurs on Mac OS X.  It is in the Pinstripe theme.
No border-style was specified in preferences.css for border-left on unselected
icons, but a border-style was specified for selected ones.  Add
border-style:solid to border-left for unselected icons, matching selected icons
and border-right.
Attachment #181786 - Flags: review?(mconnor)
Comment on attachment 181786 [details] [diff] [review]
Ritalin for preference pane icons

move this to Kevin, since he owns the theme and all.
Attachment #181786 - Flags: review?(mconnor) → review?(kevin)
Josh, can you also take a look at this, since Kevin's not here for another
couple days.  At this rate, I need a Mac.
Comment on attachment 181786 [details] [diff] [review]
Ritalin for preference pane icons

looks fine to me as long as someone has tested the fix. I can't try it out at
the moment
Attachment #181786 - Flags: review?(kevin) → review+
I tested it.  It does what it's supposed to, nothing more and nothing less.
Does this need sr, or can it be committed?
needs approval-aviary1.1a
Status: UNCONFIRMED → NEW
Ever confirmed: true
Comment on attachment 181786 [details] [diff] [review]
Ritalin for preference pane icons

Requesting
Attachment #181786 - Flags: approval-aviary1.1a?
Comment on attachment 181786 [details] [diff] [review]
Ritalin for preference pane icons

a=asa
Attachment #181786 - Flags: approval-aviary1.1a? → approval-aviary1.1a+
This has approval-aviary1.1a+, is anything else needed?
Assignee: bugs → mark
No. I'll check it in tomorrow.
Whiteboard: [checkin needed]
Checking in preferences.css;
/cvsroot/mozilla/browser/themes/pinstripe/browser/preferences/preferences.css,v
 <--  preferences.css
new revision: 1.5; previous revision: 1.4
done
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Target Milestone: --- → Firefox1.1
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.