random crash after logon by SSL [@ nsSubstring::Replace]

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
13 years ago
7 years ago

People

(Reporter: Klaus Jensen, Unassigned)

Tracking

({crash})

Trunk
x86
Windows 2000
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs retesting with Java / nordea.dk bank account], crash signature, URL)

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050424 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050424 Firefox/1.0+

address https://www.netbank.nordea.dk/netbank/index.js
but requires key and password

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1. go to site
2. logon
3. randomly craches

Actual Results:  
dr watson started closing firefox.exe

Expected Results:  
no crash
(Reporter)

Comment 1

13 years ago
Created attachment 181794 [details]
dr. watson event log
(Reporter)

Comment 2

13 years ago
Created attachment 181798 [details]
http://www.onlineinvestering.nordea.dk/oiwebsite.nsf press "Log På"

Comment 3

13 years ago
Dr. Watson stacks are of little use. When Firefox crashes does talkback start?
If it does we need the talkback ID. Talkback can be found in Mozilla
Firefox\components\talkback.exe

Comment 4

13 years ago
WFM - Opening http://www.onlineinvestering.nordea.dk/oiwebsite.nsf and pressing
"Log På" did not crash Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050425 Firefox/1.0+ with Java(TM) 2 Platform Standard Edition 5.0.

Updated

13 years ago
Keywords: crash
(Reporter)

Comment 5

13 years ago
I installed the newest firefox because talkback is not default in one of the
dayly builds, thats weired.

Provoked 2 crasched at these 2 sites, got the following talkback ID:
TB5392723H
TB5392868Q

I also saw that the browser hang i some situation! I don't know how to report
that problem back

Comment 6

13 years ago
Incident ID: 5392723
Stack Signature	nsCOMPtr_base::assign_with_AddRef 9b1ddef6
Product ID	FirefoxTrunk
Build ID	2005042612
Trigger Time	2005-04-27 02:39:18.0
Platform	Win32
Operating System	Windows NT 5.0 build 2195
Module	xpcom_core.dll + (000010ad)
URL visited	http://www.onlineinvestering.nordea.dk/oiwebsite.nsf
User Comments	
Since Last Crash	156 sec
Total Uptime	156 sec
Trigger Reason	Access violation
Source File, Line No.
c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/xpcom/build/nsCOMPtr.cpp,
line 89

Stack Trace 	
nsCOMPtr_base::assign_with_AddRef 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/xpcom/build/nsCOMPtr.cpp,
line 89]
0xf18b0c24


Incident ID: 5392868
Stack Signature	ntdll.dll + 0x4ca14 (0x77fcca14) 419e72e2
Product ID	FirefoxTrunk
Build ID	2005042612
Trigger Time	2005-04-27 02:52:08.0
Platform	Win32
Operating System	Windows NT 5.0 build 2195
Module	ntdll.dll + (0004ca14)
URL visited	http://www.onlineinvestering.nordea.dk/oiwebsite.nsf
User Comments	
Since Last Crash	57 sec
Total Uptime	213 sec
Trigger Reason	Access violation
Source File, Line No.	N/A

Stack Trace 	
ntdll.dll + 0x4ca14 (0x77fcca14)
ntdll.dll + 0x4d039 (0x77fcd039)
ntdll.dll + 0x4cdc1 (0x77fccdc1)
MSVCRT.DLL + 0x1532 (0x78001532)
MSVCRT.DLL + 0x14cf (0x780014cf)
nsSubstring::Replace 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/xpcom/string/src/nsTSubstring.cpp,
line 447]
nsAString::Append 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/xpcom/string/src/nsTAString.cpp,
line 344]
nsGenericElement::GetContentsAsText 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/content/base/src/nsGenericElement.cpp,
line 3824]
nsHTMLScriptElement::GetText 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/content/html/content/src/nsHTMLScriptElement.cpp,
line 510]
nsScriptLoader::ProcessScriptElement 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/content/base/src/nsScriptLoader.cpp,
line 575]
nsHTMLScriptElement::MaybeProcessScript 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/content/html/content/src/nsHTMLScriptElement.cpp,
line 661]
nsHTMLScriptElement::BindToTree 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/content/html/content/src/nsHTMLScriptElement.cpp,
line 455]
nsGenericElement::AppendChildTo 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/content/base/src/nsGenericElement.cpp,
line 2705]
HTMLContentSink::ProcessSCRIPTTag 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/content/html/document/src/nsHTMLContentSink.cpp,
line 4173]
HTMLContentSink::AddLeaf 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/content/html/document/src/nsHTMLContentSink.cpp,
line 3055]
HTMLContentSink::AddHeadContent 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/content/html/document/src/nsHTMLContentSink.cpp,
line 3006]
CNavDTD::AddHeadLeaf 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/parser/htmlparser/src/CNavDTD.cpp,
line 3684]
CNavDTD::HandleToken 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/parser/htmlparser/src/CNavDTD.cpp,
line 954]
CNavDTD::BuildModel 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/parser/htmlparser/src/CNavDTD.cpp,
line 461]
nsParser::BuildModel 
[c:/builds/tinderbox/Fx-Trunk/WINNT_5.0_Depend/mozilla/parser/htmlparser/src/nsParser.cpp,
line 2074]
Version: unspecified → Trunk

Comment 7

12 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050909
Firefox/1.4 ID:2005090906

Updated

12 years ago
Summary: random crash after logon by SSL → random crash after logon by SSL [@ nsSubstring::Replace]
The java applet on the login screen crashed my browser without talkback or dr watson coming up on the first attempt, and the screen loaded on the second attempt.

I suspect this is something to do with the Java applet, but there's definitely something going on. Confirming with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20070101 Minefield/3.0a2pre 
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: bross2 → nobody
Klaus, Stephanie, still getting crashes on this site?  If so, a new stack would be nice.  If not, please resolve as WFM.

(I don't have Java installed so I'm not of much use here.)
Whiteboard: [needs retesting with Java / nordea.dk bank account]
Jonas, is the stack in comment 6 enlightening?
(Reporter)

Comment 11

8 years ago
I don't see crashes any longer with newer installation so suggest to close
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsSubstring::Replace]
You need to log in before you can comment on or make changes to this bug.