A background image in a table should fill the entire table?

VERIFIED INVALID

Status

()

P3
normal
VERIFIED INVALID
19 years ago
18 years ago

People

(Reporter: tomwuttke, Assigned: karnaze)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
If a table tag has a background= property, I would expect the entire table area 
to be filled with one large tile of the image, as it does in IE.  What Mozilla 
and Navigator 4.5 are doing is applying the background image to each table cell 
individually rather than to the table as a whole.  (see example in both 
browsers) 

I looked at the CSS spec, and I don't see any provisions for this strange 
behavior.  What do you make of this?   I can use div tags as a hokey 
workaround, but I'd like to know the story behind the interpretation of the 
spec.

Thanks!

Comment 1

19 years ago
Changing component to HTML Tables
Assignee: troy → karnaze
Component: Layout → HTMLTables
QA Contact: petersen → chrisd
(Assignee)

Comment 2

19 years ago
You are seeing the NavQuirks behavior. You need <!DOCTYPE HTML PUBLIC 
"-//W3C//DTD HTML 4.0//EN" "http://www.w3.org/TR/REC-html40/strict.dtd"> to get 
the correct behavior. Marking invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

19 years ago
OK thanks!  That did the trick.  I passed this on to our content developers as 
well.  You can go ahead and close this.

Comment 4

19 years ago
Verified invalid per reporter comments.
Status: RESOLVED → VERIFIED

Comment 5

18 years ago
*** Bug 68661 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
*** Bug 69221 has been marked as a duplicate of this bug. ***
Making this no longer a quirk (i.e., use standard mode behavior all the time) is
covered by bug 4510.
*** Bug 74297 has been marked as a duplicate of this bug. ***
*** Bug 80710 has been marked as a duplicate of this bug. ***
*** Bug 80710 has been marked as a duplicate of this bug. ***

Comment 11

18 years ago
I think this sould not be marked INVALID since using strict mode causes some 
other layout changes as well.
The background image should fill the entire tabel also in quirk-mode!
You need to log in before you can comment on or make changes to this bug.