Need comment box for developers to communicate with add-on testers during upload

RESOLVED DUPLICATE of bug 316930

Status

RESOLVED DUPLICATE of bug 316930
14 years ago
3 years ago

People

(Reporter: mocking, Unassigned)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

When uploading extensions, it is sometimes useful for the developer to directly
communicate something to the Extension Tester. Therefore there should be a
textbox for the Tester's eyes only.

For example, my uploaded extension was denied and the reason was:

"Editor's Comments:
Didn't do anything for me"

That doesn't give me any information on what happened. And since I am confident
that my extension DOES do something, my only course of action is to upload it
again exactly like before.

If I was given the option to communicate with the extension tester, I would have
directed him/her to my homepage to make sure that they knew how my extension is
suppose to work, because I suspect that the tester just installed it; saw no
obvious changes; and rejected it.

Reproducible: Always

Steps to Reproduce:

Comment 1

14 years ago
If its not obvious to the tester, then it won't be obvious to the public who are
installing it.  Try adding more information to the description.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

14 years ago
Some extensions are only useful under certain situations. I can describe that
situation, but I don't expect the tester to be able to simulate it. And if they
cannot simulate it, they cannot test it.

That's why I wanted to post a link to my homepage, which contains a simulated
demo environment for them to test out my extension. But I do not want to put a
link to my homepage as part of the "short description", since there is already a
link to my homepage on the "listings page".

For the casual reader, I expect them to download my extension only if they've
experienced that situation before and feel that my extension would be helpful
under that situation.

As an example, think of the Adblock extension: Advertisements are currently very
intrusive so the author does not need to describe them or simulate them for the
tester. But imagine a time when advertisements were less intrusive. How could an
extension tester test Adblock without having encountered advertisements? Does
the author have to describe the scenario of encountering ads in his product
description, or is it sufficient for him to just say "it stops advertisements"
and make his extension available and only those people who have experienced ads
will need to download his extension. Maybe the scenario description would be fit
for a "long description" but not a "short description".

Comment 3

14 years ago
*** Bug 292531 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 4

13 years ago
I came back here because I just can't stand some of the testers; whom are really testing my patience (pun intended). First I am certain that my extension works for 90% of the people. Code wise, my extension is simple and it is unlikely that anything unpredictable will happen. I also sent it to 5 friends to test, just to make sure that it works and that there aren't any quirks caused by Firefox itself. Plus my extension has worked in the past and it has gotten good comments on UMO. But life is unpredictable and it is inevitable that there are certain environments that I haven't envisioned that will cause my extension to fail. And it may just so happen that I encounter a tester that lives in such an environment. Now it is impossible for me to know the technical proficiency of the tester, because UMO makes no public statement of their testers' standards. (e.g., Did the tester have BonziBuddy installed, which is conflicting with my extension?) So I can only assume the worst case scenario and treat the testers as amateurs and walk them through step by step in debugging why my extension did not work on their system, yet works on 90% of the world's systems. I cannot just give the tester the benefit of the doubt and assume that it is always my fault that the extension didn't work. Firstly, even if it was my fault, chances are that the environment-specific bug may never be discovered in my lifetime. Secondly, I would go bald with stress wondering whether I just wasted my time giving a rookie the benefit of the doubt or whether I've rightfully humbled myself by give a professional the benefit of the doubt. Anyways, in conclusion, we need this comment box or at least some way of contacting the tester through email in order to inquire whether they need me to walk them through step by step and whether it was really my fault or their fault. And then find relief and finally hold hands and sing Kumbaya.
AMO BUGSPAM FOR COMPONENT MOVE AND DELETE (FILTER ME)
Component: Listings → Web Site
(Reporter)

Comment 6

12 years ago
Hi, it's me again! I'm here to share with you an experience I had while submitting an extension.

When I submitted version 0.4 of my RiteOfTongue extension, I changed the communication protocols and so added this line in the "developers comments" section:

> "Users behind a firewall (or router) should allow outgoing 
> connections on port 2628 to access the Dict server. Users 
> behind a proxy server may encounter problems for the same 
> reason."

Then I submitted the extension and got this reply back:

> "Unfortunately this extension did not work for me at all. No 
> matter which web form I chose and no matter what word I typed, no 
> suggestions were ever offered. It simply said "Wait...". 
> I tried several of the included online dictionary servers with 
> no luck at all. I have therefore had to deny approval. Please 
> fix and re-submit. Thanks"

Then I removed the comments from the "developers comments" and moved them to the "version notes". I submitted the same extension again and got this reply:

> "Please do not waste our time resubmitting an unfixed 
> extension which has already been rejected. If you fix it and 
> re-submit it, I will take a look again. Cheers"

Now I really wanted the tester to read my comments and I wasn't prepared to write "DEAR TESTER, please read what I wrote in the comments section!!!", because then the public would be able to see what I wrote. So then I removed the comments from the "version notes" and appended it to the extension "description". Then I submitted it again and got this reply:

> "Success! The trick was change the firewall on my router 
> to allow outgoing connections on the non-standard port. 
> It did work through my two chained proxy servers (apache 
> and adzapper) btw :)  Thanks for the updating the instructions 
> and making the requirements clearer. Cheers"

Now how else am I supposed to provide information to the tester? Am I supposed to make the instructions and troubleshooting information as part of the extension description from now on?

A few days ago I submitted version 0.1.5 of my YMail Notifier extension. In my "developer comments" section, I included this line:

> "IMPORTANT: This extension CANNOT check for new mail when 
> you are physically at the Yahoo! Mail website. This is because 
> Yahoo! RESETS the mail counter whenever you visit their mail 
> website. If you want to test this extension, be sure to send 
> yourself an email from another mail account!"

And the extension tester replied with this:

> "Everything seems to work correctly, except for actually 
> telling me I have new messages. I sent myself multiple test 
> emails while logged into Yahoo Mail and did the manual check 
> and was continually told I had no new messages when I have 
> 3 unread in my inbox. Please fix and re-submit."

Just now I copied the line from my "developer comments" to the "version notes" section and submitted the extension again. I'll keep you updated on what happens.

Comment 7

12 years ago
Mocking: Please be aware that only the add-on description is visible in the approval queue, not the developer comments or the version notes. 

Perhaps this needs to be remedied.
(Reporter)

Comment 8

12 years ago
(In reply to comment #7)
> Mocking: Please be aware that only the add-on description is visible in the
> approval queue, not the developer comments or the version notes. 

Thanks. That explains a lot. I actually feel relieved now, knowing that (1) It wasn't my extension that was behaving unexpectedly; (2) My instructions were obvious as I had thought, but just not made available; (3) Extension testers are not stupid; (4) The system works, but you just need to know how.

Comment 9

12 years ago
I'm all for this, so I'm reopening it to dupe it to the newer bug where fligtar is doing the work :)
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
Summary: Need comment box for developers to communicate with Extension Testers during upload → Need comment box for developers to communicate with add-on testers during upload

Comment 10

12 years ago

*** This bug has been marked as a duplicate of 316930 ***
Severity: minor → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago12 years ago
Component: Public Pages → Developer Pages
Resolution: --- → DUPLICATE
Target Milestone: 1.0 → ---
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.