Wrong direction of displaying of Syriac script

VERIFIED DUPLICATE of bug 240606

Status

()

VERIFIED DUPLICATE of bug 240606
14 years ago
14 years ago

People

(Reporter: jkovacic, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; sl-SI; rv:1.7.6) Gecko/20050318 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; sl-SI; rv:1.7.6) Gecko/20050318 Firefox/1.0.2

Exactly the same as reported at 291904 (Mozilla Suite)

Syriac (Unicode range between U+0700 and U+074F) is supposed to be writtten from
right to left (like Arabic which is displayed fine) but Mozilla and Firefox
display it from left to right

Reproducible: Always

Steps to Reproduce:
1. If you don't have one, get and install a font supporting Syriac (e.g. the one
at http://titus.fkidg1.uni-frankfurt.de/unicode/tituut.asp - free for
noncommercial use)
2. Open http://en.wikipedia.org/wiki/Syriac_language with various browsers
(Firefox, Mozilla, Opera, MSIE)
3. Compare the letter order at the first table line (yellow background) where
Syriac is written also in Syriac letters

Actual Results:  
Syriac characters displayed in left to right direction

Expected Results:  
Mozilla and Firefox should display the word in Syriac in right to left direction.

http://en.wikipedia.org/wiki/Syriac_language and
http://en.wikipedia.org/wiki/Syriac_alphabet should provie links to further
information about Syriac script

Bug report 291904 (Mozilla Suite)

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 240606 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
v=aha
Status: RESOLVED → VERIFIED

Comment 3

14 years ago
Using Firefox 1.0.4 for Windows 98SE, and being the primary author of both
http://en.wikipedia.org/wiki/Syriac_language and
http://en.wikipedia.org/wiki/Aramaic_language, I notice that the Syriac names at
the top of the infobox (in the yellow box) appear back to front in the former
but correctly for latter. The only difference is that the latter sample is
offset with  break and paragraph tags.
You need to log in before you can comment on or make changes to this bug.