context menu partly outside visible screen area

VERIFIED DUPLICATE of bug 245163

Status

()

Firefox
Menus
VERIFIED DUPLICATE of bug 245163
13 years ago
11 years ago

People

(Reporter: Willem Kossen, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; nl-NL; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; nl-NL; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

I use a lot of extensions which elongates my right click context menus. 
When i right click a couple of lines below the upper part of the web page I'm
viewing, the top of the context menu is not visible on the screen (above the
visibla part).

The context menu should never be above the upper most border of the screen. If
it were to drop beneath the lower part of the screen, raising the resolution
might be a solution, but with the upper part there is no solution. Even better
would be to have more columns in the contextmenu if it doesn't fit the height of
one screen.

Reproducible: Always

Steps to Reproduce:
1. make sure you have a long context menu (lots of extensions will do that)
2. right click a couple of lines below the upperpart of the page you're viewing
3. the contextmenu will only be partly visible

Actual Results:  
the context menu was not completely visible, part was above the viewable area.

Expected Results:  
moved the contextmenu down so it fits the screen. If it still wouldnt fit
(beneith the lower part) put it into two or more columns. If it still wouldnt
fit, tell the user to increase resolution or to uninstall some extensions...

i have a lot of extensions installed that do add lines to the right click
context menu. If you want a screenshot of the menu, just ask.

Comment 1

13 years ago
This is already fixed on trunk. Will be availabe in Firefox 1.1

*** This bug has been marked as a duplicate of 245163 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Updated

11 years ago
QA Contact: bugzilla → menus
You need to log in before you can comment on or make changes to this bug.