Charset specification in META http-equiv tag "Content-Type" should have precedence over HTTP header specification

RESOLVED DUPLICATE of bug 238488

Status

()

RESOLVED DUPLICATE of bug 238488
14 years ago
14 years ago

People

(Reporter: bugs_mozilla_2q1889, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050422 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050422 Firefox/1.0.3

The charset definition within a HTML page should have precedence over general
HTTP header specifications of the charset. Try the above URL. Even with UTF-8
set as standard in Firefox, it still switches to ISO8859-1 although the META tag
inside the HTML document's header says "UTF-8".

Reproducible: Always
(Reporter)

Comment 1

14 years ago
Ok, I have fixed the problem at that URL by creating a .htaccess file that
prevents Apache from setting the charset encoding. But the problem itself still
exists.

Comment 2

14 years ago
*** This bug has been marked as a duplicate of 238488 ***

*** This bug has been marked as a duplicate of 238488 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.