page anchors(in-page bookmarks) do not work inside a table.

RESOLVED DUPLICATE of bug 176449

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 176449
13 years ago
13 years ago

People

(Reporter: Barry Smoke, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

In the page
https://forum.legaudit.state.ar.us/barry/PersonnelDirectory_bug_demo.html, the
bookmarks, or anchor links do not work, although they work fine in other browsers.
I have found a workaround by converting the tr's to tables, which is impracticle.
here is a demo
workaround:https://forum.legaudit.state.ar.us/barry/PersonnelDirectory_workaround.html



Reproducible: Always

Steps to Reproduce:
1.put anchors inside a table
2.
3.

Actual Results:  
anchors break

Expected Results:  
anchor links followed correctly
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 2

13 years ago
I have verified this in the latest 1.5 beta 1.
I can't believe this problem has not been more widespread.
Are we the only ones using anchors in <tr>?
The demo links still work, and can be verified.

Comment 3

13 years ago
This is a dupe of bug 176449. You aren't the only one, but most people either
place the anchor in the first table cell or, if they don't care about older
browsers, simply use <tr id="C"> instead of <tr><A NAME="C"></A>.

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 176449 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.