Won't restart in same online session

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Paul Walker, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: Firefox 1.0.3

I cannot get Firefox 1.0.3 to restart during a session if I close it.
I have to reboot to use it again

Reproducible: Always

Steps to Reproduce:
1.Use Firefox 1.0.3
2. Close it
3. Attempt to reopen Firefox---nothing happens

Actual Results:  
Firefox will not reopen until I reboot.

Expected Results:  
Opened normally

Using Littlefox theme, latest version
After you close firefox check the task manager (CTRL-ALT-DEL) and stop any
firefox.exe process still running. I don't know the root cause of your problem tho.
try to run firefox in the safemode (using the firefox safemode entry in the
windows startmenu) after you closed FF.
Does FF still hang on close ?
(Reporter)

Comment 3

13 years ago
Cancelling the Firefox.exe in Task Manager solves the problem of rebooting. 
I even tried reinstalling (on top of last install) but it didn't fix the
problem.  I'm using 3 machines (2 Win 2K Pro, 1 Win XP Pro) and this Win 2K Pro
is the only one with the problem.  1 other Win 2K pro machine came up with a
slightly different UI on alternate loads, but that has gone away now.  All using
1.0.3.
(Reporter)

Comment 4

13 years ago
I cleared the error by uninstalling 1.0.3 and then reinstalling.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

13 years ago
I had the same symptoms on another machine.
I had to do the same process (uninstall-reinstall) on another machine today!
Both machines were Win 2K Pro.
Closing Firefox does not seem to release firefox.exe from the running tasks
(still running in task manager)
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Whiteboard: REOPENED
you didn't answer my question and this is wfm for me on win2k3,win2k and winXP
and also many other people (that includes Mozilla QA testing before the release).

-> wfm

This kind of error is usually caused by installed extensions.
(and extensions bugs doesn't belong into bugzilla)

Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
Whiteboard: REOPENED
(Reporter)

Comment 7

13 years ago
(In reply to comment #6)
> you didn't answer my question and this is wfm for me on win2k3,win2k and winXP
> and also many other people (that includes Mozilla QA testing before the 
release).
> -> wfm
> This kind of error is usually caused by installed extensions.
> (and extensions bugs doesn't belong into bugzilla)
It may be due to installed extensions, but I have no idea which one.  This kind 
of stuff is slowly driving me back to IE, even though I like Firefox, and the 
extensions are one of the chief reasons I like Firefox


sorry but yxou have to ask the extension author what he did wrong.
It's very easy to see if an extension is broken if it works in the Firefox
safemode. With try&error (if FF still runs in the normal mode you can disable
the extensions one by one)

(Reporter)

Comment 9

13 years ago
Apparently I'm not the only one.  You have some bad publicity.
http://www.scotsnewsletter.com/68.htm#ffprobs
"The thing is, in order to do well in the market place long-term, a Web browser
has to work better than this. You can't roll out x.x.1 security patches and
break people's installations. And if you're going to support third-party
extensibility, I think you have to fully support it. If as I believe is probably
the case, that an extension (or other customization) conflict proves to be the
culprit, then Mozilla needs to think hard about integrating and fully testing
the common functionality that the more popular extensions provide."
I agree with him.  Apparently the problem started with 1.0.2
You need to log in before you can comment on or make changes to this bug.