Closed Bug 292008 Opened 16 years ago Closed 16 years ago

E-Mail address with german umlaut in plain name not parsed properly

Categories

(Thunderbird :: Message Compose Window, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 254519

People

(Reporter: hadmut, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050421 Firefox/1.0.3 (Debian package 1.0.3-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050421 Firefox/1.0.3 (Debian package 1.0.3-2)

Hi,

I just received an e-mail from someone with several Cc addresses in the form

"Lastname, Firstname" <some@addre.ss>

where some of the Lastnames contained german Umlauts (ä,ö,ü,...). 
When replying with a reply all (I guess a normal reply has the same problem)
these addresses where not parsed proberly, each of these addresses was 
split into two parts and made two sepearate Cc addresses, one as 

  Lastname

and the other as 

  Firstname <some@addre.ss>



Reproducible: Always

Steps to Reproduce:
1. Send yourself an email, use Sender or Cc addresses of the form 
   "Lastname, Firstname" <some@addre.ss>
   but include a german Umlaut (äöüÄÖÜß) in the Lastname. 
2. Read the mail and press "Reply" or "Reply all"
3. Check the address list in the generated mail window

Actual Results:  
Address split into two parts

Expected Results:  
Address not split, but used as it is.
Related to Suite bug 135428/Thunderbird bug 290738?

*** This bug has been marked as a duplicate of 254519 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.