Find as you type highlight feature causes slight text re-arrangement.

RESOLVED DUPLICATE of bug 275040

Status

()

Toolkit
Find Toolbar
--
major
RESOLVED DUPLICATE of bug 275040
13 years ago
10 years ago

People

(Reporter: Chris, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

On the web page http://www.chrisjhaig.co.uk/new-structure.htm using the  find as
you type 'highlight' feature may cause the text on screen to be re-arranged. For
example, typing in the word 'start' and clicking on highlight will simply
highlight the word as expected.

However, type in the number '12' and select the highlight option will cause the
text in that paragraph to be altered in what appears to be a random manor.

For whatever reason, it seems as though Firefox will pinpoint the two values of
'12', take the text BEFORE the first '12' and place it AFTER the second '12'.
The first twelve will then take control of the CSS :first-letter property and
absorb it's value. Pressing the highlight button again then seems to make the
text randomly rearrange itself.

Searching for the word 'pick' also causes random placement of text.

On further attempts, it seems almost any search and highlighting will cause the
page text to be randomly jumbled about.

Reproducible: Always

Steps to Reproduce:
1. Search for a word on the web page.
2. Press the highlight button.
3. Again, press the highlight button.

Actual Results:  
Text begins to randomly re-arrange itself.

Expected Results:  
Found words are simply highlighted as expected.
(Reporter)

Comment 1

13 years ago
Created attachment 181908 [details]
Screen grab of page before search and highlight.
(Reporter)

Comment 2

13 years ago
Created attachment 181909 [details]
Screen grab of page after search and highlight.

*** This bug has been marked as a duplicate of 275040 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.