Closed Bug 292029 Opened 17 years ago Closed 17 years ago

Extensions will still not install

Categories

(Toolkit :: Add-ons Manager, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 291946

People

(Reporter: stevee, Assigned: bugs)

Details

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050422
Firefox/1.0+

Beast build with the second part of bug 291831 checked in.

Installing extensions doesn't seem to work. They always remain listed in the EM
as "<extension> will be installed the next time firefox is restarted" - but no
matter how many times I restart firefox, the extension's status in the EM
remains unchanged.

1. Create a new profile and start firefox.
2. Go to http://www.blueprintit.co.uk/~dave/web/firefox/jsoptions/index.html and
choose to install v1.0 of the JS Advanced Options extension
3. Allow the site to install extensions, and install the extension.
4. Note the EM says "Javascript Options will be installed the next time firefox
is restarted"
5. Also note the JS Console reports:

Item Installed via directory addition to Install Location: app-global Item ID:
{972ce4c6-7e08-4474-a285-3208198ce6fd}, attempting to register...

Item Installed/Upgraded at Install Location: app-global Item ID:
{972ce4c6-7e08-4474-a285-3208198ce6fd}, attempting to register...

(Don't know if this is relevent)

6. Restart Firefox.
7. Notice that the extension is not installed, and in the EM it still says
"Javascript Options will be installed the next time firefox is restarted"
8. Restart Firefox many times, notice that the extension is never installed.

This happens for FoxyTunes 0.1.1, FlashGot 0.5.9.1 and Tabbed Browser
Preferencse 1.2.4 - I have not tried any more extensions. I have also not tried
an existing profile.
probably a dupe of bug 291946
and should be fixed by bug 291666
( I'll mail you the patch to try it out Steve )

*** This bug has been marked as a duplicate of 291946 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.