Save attachment name error if contain "_" in file name

RESOLVED DUPLICATE of bug 252309

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 252309
13 years ago
9 years ago

People

(Reporter: THSCHPO, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Attachment can not save a completed name if the name contain "_" such as
"a_a.dwg" it will save "a" without instead of "a_a.dwg" while IE ca save a
proper name.

Reproducible: Always

Steps to Reproduce:
1. save attachment from yahoo mail which contain "_" in name such as "a_a.dwg"
2. save dialog will pop up which only "a" name
3. save file to PC

Actual Results:  
only "a" will be save

Expected Results:  
show defult file name "a_a.dwg"
This is a problem with how yahoo sends the downloads.

*** This bug has been marked as a duplicate of 252309 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.