Closed Bug 292056 Opened 15 years ago Closed 14 years ago

Named anchors may not center properly in view once images are loaded.

Categories

(Core :: Layout, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 60307

People

(Reporter: bugzilla, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

I've noticed a sporadic problem with named anchors centering properly when a
page loads.  This problem isn't site-specific, but I've included the above URL
as a good test case.  Basically I've found, repeatedly, that when a large page
loads with a URL using a named anchor, the anchor seeks immediately, but may
then become displaced as images are loaded.  It seems to me the problem is the
fact that as the images on a page are loaded, the physical size of the page
actually changes.  This causes a scrolling effect, and displaces the view from
the location of the anchor.  For example, just now I had taken the link above
(http://vspx27.stanford.edu/cgi-bin/allprojects#1278).  Firefox immediately
seeks to the 1278 anchor, but that page includes many large images.  As 'fox
proceeded to load images it would scroll up and down as the page was dynamically
resized.  Unfortunately this results in me looking at anywhere from the wrong
line, to the entirely wrong paragraph.  This problem crops up somewhat
sporadically as it seems to mostly be related to the number, location, and size
of images on any given page.  

So far the only browser I've seen that really handles this issue well is Opera.
 Their solution is to load all images prior to seeking the anchor, because
obviously once the page is fully loaded it wont continue resizing.  I'm not
saying this is the best solution, but I think it should be addressed.

Reproducible: Always

Steps to Reproduce:
Possibly related are bug 103279 and bug 60307  (see in particular comment #9 of
bug 60307).
(In reply to comment #1)
> Possibly related are bug 103279 and bug 60307  (see in particular comment #9 of
> bug 60307).

Yes, it looks like these bugs do deal with some of the root cause of the
problem.  Do you think we should close this bug assuming those bugs will also
resolve this, or would it be better to leave this bug specifically for this
issue and just set the other bugs as blocking?  My only concern is I don't think
this specific problem is in the other bug descriptions so it may be overlooked
in future solutions.
I confirm this bug. It is uncomfortably to look pages with large number of
photo. The only solution is to refresh (F5) page or to press "back" and press
the same link. In this cases images are loaded from cache and bug is not visible.

I hope this misunderstanding bug will be fixed without delay.

Example of page where it well-visible:

http://forum.b.gz.ru/showflat.php?Cat=&Board=Common&Number=2829867#Post2829867
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
Maybe if the staff would actually read these bugs in the first place there'd be
more comments...  Keep it open.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Looking over this again, and bug 60307, I think this belongs in Core->Layout. 
I'll also tweak up the summary.
Assignee: firefox → nobody
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Summary: Named anchors may not center properly when images are loaded. → Named anchors may not center properly in view once images are loaded.
Version: unspecified → Trunk
This /is/ bug 60307 - note in particular that most of the duplicates are
describing precisely the same thing.

*** This bug has been marked as a duplicate of 60307 ***
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.