improve seamonkey's local profile support

RESOLVED FIXED

Status

RESOLVED FIXED
14 years ago
3 years ago

People

(Reporter: Biesinger, Unassigned)

Tracking

({helpwanted})

Trunk
x86
All
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

bug 291033 added the ability to have a "local" profile directory

that directory should be salted, like the normal profile dir
and, for manually created directories in a path outside of application data, the
temp directory should maybe be identical to the profile dir.

Updated

14 years ago
OS: Linux → All

Comment 1

13 years ago
*** Bug 296890 has been marked as a duplicate of this bug. ***

Comment 2

13 years ago
FYI, this prevents profile deletion (via Profile Manager) from deleting XUL.mfasl and Cache (assuming the user didn't change their Cache to live inside the salted directory).

The reason is that the profile manager assumes that the directory isn't salted because it isn't the only child of its parent:

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/profile/src/nsProfile.cpp&rev=1.316&mark=1507-1528#1481

Comment 3

12 years ago
AFAIK, this is fixed by using the toolkit code now.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Depends on: 328887
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.