safely resume full session including opened tabs

VERIFIED DUPLICATE of bug 159357

Status

()

Firefox
Tabbed Browser
--
enhancement
VERIFIED DUPLICATE of bug 159357
13 years ago
13 years ago

People

(Reporter: peter gervai, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050421 Firefox/1.0.3 (Debian package 1.0.3-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050421 Firefox/1.0.3 (Debian package 1.0.3-2)

The best example is probably Opera: if I open anything new, it saves a temporary
session file, so if I exit the program or it crashes (oh, I know, firefox never
does ;->) restarting it resumes *everything* there was before, including all
opened windows and tabs. This is currently the main reason I use Opera, because
I love to keep 100+ tabs open and get them reopened the next morning without
manual intervention. 

(Btw Opera does cache these pages, so startup actually doesn't refresh them
immediately but gets the cached content if possible, they solved this way the
problem of slow startup and high CPU load at start.)

Would be really neat to have.

[I didn't find an existing request, so I hope this isn't duplicate.]


Reproducible: Always

Steps to Reproduce:
1. open 100+ tabs
2. exit firefox
3. start firefox 

Actual Results:  
One page opened (the last visited tab's content)

Expected Results:  
100+ tabs opened, the last visited being active.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 159357 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.