Someone with editbugs but without canconfirm can still confirm bugs

RESOLVED DUPLICATE of bug 273825

Status

()

--
minor
RESOLVED DUPLICATE of bug 273825
14 years ago
14 years ago

People

(Reporter: mpt, Unassigned)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.6) Gecko/20050405 Epiphany/1.6.1 (Ubuntu) (Ubuntu package 1.0.2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.6) Gecko/20050405 Epiphany/1.6.1 (Ubuntu) (Ubuntu package 1.0.2)

This is a test of the emergency bug confirmation system. Apologies for the noise.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
Steps to reproduce:
1.  Get a friendly Bugzilla admin to set your Bugzilla permissions to
    canconfirm=false, editbugs=true.
2.  Report a bug. It shows up as unconfirmed.
3.  Confirm the bug.

This doesn't make any sense. You can't report a bug as confirmed, but you can
confirm it, though you have canconfirm=false. Maybe these boolean flags should
be replaced with a scale (candonothing, canconfirm, canedit).
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
Summary: test → Someone with editbugs but without canconfirm can still confirm bugs
Version: unspecified → 2.19.1

Comment 2

14 years ago
Users having 'editbugs' privs can confirm bugs, as they are allowed to edit any
aspect of bugs, including confirmation.

There was a bug when entering a new bug which prevented users having 'editbugs'
privs from confirming it. This has been fixed in bug 273825 and now we are fully
consistent.


*** This bug has been marked as a duplicate of 273825 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.