download manager incorrectly renames duplicate files

RESOLVED DUPLICATE of bug 231048

Status

()

RESOLVED DUPLICATE of bug 231048
14 years ago
11 years ago

People

(Reporter: pperpich, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Download manager does not rename duplicate files correctly.  It seems to look
for the first "-1." instead of the last.  for example, downloading a few copies
of tightvnc dev version ends up causing this:

tightvnc-1.3dev6-setup.exe
tightvnc-2.3dev6-setup.exe
tightvnc-3.3dev6-setup.exe
tightvnc-4.3dev6-setup.exe
tightvnc-5.3dev6-setup.exe

Reproducible: Always

Steps to Reproduce:
1.  See details


Actual Results:  
files renamed incrrectly

Expected Results:  
added a "-1" to the end of the filename...not in the middle.

*** This bug has been marked as a duplicate of 231048 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.