Disable "Quoted-printable" by default

VERIFIED FIXED in M15

Status

MailNews Core
Composition
P3
normal
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: BenB, Assigned: rhp (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Mozilla sends out quoted-printable encoded "plain text" mails by default.
Unfortunately, they aren't that "plain", i.e. English text is inconvient to read
and German text is nearly unreadable.

What's wrong with "7bit"/"8bit"?

Comment 1

18 years ago
cc: phil
QA Contact: lchiang → pmock

Comment 2

18 years ago
Are we talking about the body or the headers? There's a bunch of complicated 
prefs and logic for this. I bet rhp knows it best. As I remember, the 4.x 
defaults are QP for 8bit headers, but not for bodies.
(Reporter)

Comment 3

18 years ago
I was talking about the body, but the same holds true for the subject.

At least from a usage point of view, I don't know about the technical problems
in details. Shouldn't SMTP treat headers and the body the same? What was the
reason, 4.x made the difference? Does it still exist (some time passed until 4.0
release)?
(Assignee)

Comment 4

18 years ago
Yes, we do default to QP, but if you set the pref "mail.strictly_mime" to 
false, then it will override the default.

- rhp
reassign to rhp
Assignee: ducarroz → rhp
(Assignee)

Comment 6

18 years ago
Ok, defaults to FALSE now.

- rhp
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

18 years ago
Rich, subjects are still encoded.
(Assignee)

Comment 8

18 years ago
Headers must be encoded if they are not 7 bit data.
(Reporter)

Comment 9

18 years ago
I don't see this being fixed. When I create a new profile, it is still initially
set to QP.

Comment 10

18 years ago
Reopening.

Ben, when you think a bug has not been fixed, please reopen it so we don't lose
that valuable information.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 11

18 years ago
Ben,
What is set to quoted printable? I've reviewed this and it seems to work fine 
for me.

- rhp

(Assignee)

Comment 12

18 years ago
Sorry, I just tested this and it seems to work for me. Can we have someone in 
QA test this?

- rhp
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME

Comment 13

18 years ago
Suresh - can you help to verify this bug?
QA Contact: pmock → suresh

Comment 14

18 years ago
Discussed this with rhp. Re-opening the bug.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 15

18 years ago
I just downloaded the latest nightly (to ensure, that there's no corelation with
my local changes to the prefs pane). I still see QP being default

Reproduce:
1. ./mozilla -ProfileManager
2. Create new Profile
3. Open Prefs|Mailnews|Messages
4. Look at "For outgoing msgs"|"Send msgs that use 8-bit chars"

Actual result:
"Using the "quoted printable" MIME encoding" is activated

Expected result:
"As is" is activated
(Assignee)

Comment 16

18 years ago
I see what is going on...default prefs file...I will change the body to not 
default to QP.

- rhp
(Assignee)

Updated

18 years ago
Status: REOPENED → ASSIGNED
Target Milestone: --- → M15
(Assignee)

Comment 17

18 years ago
Changed the default value in the mailnews.js file.

- rhp
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 18

17 years ago
The default value for the pref "mail.strictly_mime" is set to false and is
reflected in the prefs panel when you create a new profile. Not adding vtrunk
because of preBranch fix.
Marking Verified Fixed.
WinNT 2000102008
Mac 2000102008
Linux 2000102009
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.