bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Expand NSS API to include cert_FindExtension

RESOLVED DUPLICATE of bug 292123

Status

NSS
Libraries
RESOLVED DUPLICATE of bug 292123
13 years ago
13 years ago

People

(Reporter: Alexei Volkov, Assigned: Wan-Teh Chang)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
It is important to get proper signing cert when modifying existing crl.
To get find a signing cert the following algorithm should used: check if crl has an
Authority Key Extension. If it has, when use the value of the extension to
find a signing cert. If not, then look for a cert that has proper singing
capabilities flag and has a proper trust.

This expansion is needed in order to get Authority Key Extension value from the
importing crl.

Another possibility is to move functionalities related to singing cert
discovery into NSS library.
(Reporter)

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 292123 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.