Chatzilla should support the DCC server protocol

RESOLVED WONTFIX

Status

Other Applications
ChatZilla
--
enhancement
RESOLVED WONTFIX
13 years ago
11 years ago

People

(Reporter: Glen Mailer, Assigned: Robert Ginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050421 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050421 Firefox/1.0+

The DCC server protocol is a mIRC thing that allows uers who are behind
firewalls to send files by making the receiver into a listening server.

the protocol is outlined (fairly poorly) here
http://outflux.net/software/pkgs/dccserver/protocol.txt
This is the exact protocol from the mIRC manual

Reproducible: Always

Comment 1

13 years ago
*shudder*

Need I say more? That document is so non-useful it's scary. :)

It's like DCC Chat/File on top of HTTP (like), on top of TCP, started from DCC,
from IRC, on TCP. could you /have/ any more levels of protocol?

Comment 2

13 years ago
*** Bug 292006 has been marked as a duplicate of this bug. ***

Comment 3

13 years ago
(In reply to comment #1)
> *shudder*
> 
> Need I say more? That document is so non-useful it's scary. :)
> 
> It's like DCC Chat/File on top of HTTP (like), on top of TCP, started from DCC,
> from IRC, on TCP. could you /have/ any more levels of protocol?
http://trout.snt.utwente.nl/ubbthreads/showflat.php?Cat=0&Number=125508&an=0&page=0#125508

Updated

12 years ago
OS: Windows XP → All
Hardware: PC → All

Comment 4

12 years ago
I do wonder why this would be useful for chatzilla.  I suppose you could make a plugin to do it, but it's really something that should be completely independent.  I don't even see what it has to do with irc.  Seriously considering wontfix.
(In reply to comment #4)
> Seriously considering wontfix.

To be honest, I quite agree. Additionally, to me the spec leaves lots and lots of holes as to how this is supposed to work (and apparently I'm not the only one), and I really don't fancy using Ethereal or similar to reverse-engineer the protocol.
(In reply to comment #5)
> (In reply to comment #4)
> > Seriously considering wontfix.
> 
> To be honest, I quite agree.

Make that 3 for wontfix - this is so specialized that to implement this would be code bloat for 99% or more of chatzilla's users, not to mention a waste of developer time for a feature that almost noone will use.



Comment 7

11 years ago
WONTFIX.

We won't be adding DCC Server support directly into the client; a script to provide the functionality should be possible - if it isn't, I'm OK for us to fix bugs that prevent it working.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.