cannot load javascript function from body onload

RESOLVED WORKSFORME

Status

()

Core
DOM: Events
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Prasetya, Unassigned)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

I have javascript fuonction that need to be load when page loaded. When it using
firefox, I couldn't load it.
Example :
<body onload="alert('Page loaded');"></body>

There is no problem when i try it on IE, but when I used Opera and Firefox, it
could be loaded

Reproducible: Always

Comment 1

13 years ago
Your example works for me in Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2)
Gecko/20050427 Firefox/1.0+

Perhaps you could attach a testcase?
Assignee: nobody → events
Component: JavaScript Console → DOM: Events
Product: Firefox → Core
QA Contact: javascript.console → ian
Version: unspecified → 1.0 Branch

Comment 2

13 years ago
WORKSFORME with Mozilla 1.8b2 build 2005043006 and Firefox 1.0.3 rv: 1.7.7 build
20050414 under XP Pro SP2

Prasetya, you may reopen this bug if you can provide and attach a testcase in
this bugfile where the problem can be seen and investigated.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.