getting "failed to get the nsIScriptGlobalObject. bug 95465?"

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
6 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

({assertion, testcase})

Trunk
x86
Windows XP
assertion, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
in my console I'm seeing:

"failed to get the nsIScriptGlobalObject. bug 95465?"

it happens when pressing ok after adding domain to the xpi whitelist

own build on gcc on Windows using latest trunk source
Not a layout issue.  Minimal testcase needed in any case, for bugs filed on
layout as NEW....
Assignee: nobody → general
Component: Layout → XBL
Keywords: qawanted
QA Contact: layout → ian

Updated

13 years ago
Keywords: assertion
Steps to reproduce:

(0) Visit about:
(1) Visit http://www.mozilla.org/projects/xul/tests/label.xul
(2) Click the label stating "Click this label to focus the text box to the right."  The textbox should receive focus.
(3) Click the Back button.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060131 SeaMonkey/1.5a

100% reproducible; sometimes I hit the assertion twice for the same page.  Stack coming up as attachment.
Keywords: qawanted → testcase
mmm... that looks like focus events or something.  :(

Updated

12 years ago
Depends on: 339649

Comment 5

12 years ago
Created attachment 264993 [details]
my version as smaug says event handling changed...
Assignee: xbl → nobody
QA Contact: ian → xbl

Comment 6

6 years ago
From what I can see, both stack traces have nsXBLPrototypeHandler::ExecuteHandler() just before debug/assertion/break code.

The assertion was removed as part of Bug 451680, assuming it was originally in nsXBLPrototypeHandler.cpp.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.