Closed Bug 29219 Opened 20 years ago Closed 20 years ago

Wired stock charts do not display in M13

Categories

(Core :: ImageLib, defect, P3, critical)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: dan, Assigned: ruslan)

References

()

Details

(Whiteboard: [nsbeta2+][6/15])

At wired news' stock charting page, the image containg the chart does not
display. Instead the text "dllchart' appears. I'm using mozilla M13 on WinNT
4.0(sp5).

To reproduce, simply go to the above URL and enter a ticker symbol, (eg SUNW)
then press GO.

The page works fine in Netscape 4.72 and IE5.0
WORKSFORME in M13 W95 (modulo loads of other page layout problems) and 
2000022608 W95.

We need an NT person to check this out...

Gerv
confirming bug. sorry for the spamm
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → ASSIGNED
Target Milestone: --- → M17
I'll dig into it.
-P
This is now working in every build I can lay my hands on, including the current 
one (20000428). Could it have been their problem?

Can doronr@naboonline.com, pnunn@netscape.com and/or dan@paradix.org try this 
both in new and old builds, and say what they see?

Gerv
Eli:
If this works for you, would you close the bug?
We don't have time to play with dead snakes...just make
sure its really dead.

thnx,
p
Hmm...using today's build on NT, Linux & Mac and "MSFT" as the ticker symbol, I 
see no chart.
...specifically, I see an empty image frame, which is sometimes (on Linux) 
replaced immediately by alt text (dllchart).

Clicking on the image and choosing 'View Image' from the context menu doesn't 
show any image, either.
Keywords: nsbeta2
Putting on [nsbeta2+][6/01] radar.  This work must be done by 06/01 or we may 
pull this for PR2.
Whiteboard: [nsbeta2+][6/01]
Gagan:
I'm not sure who should own this.
Once the image is generated, the imglib can display it.
If I get the chart image from 4.x and save it, mozilla
displays it fine.

Looking at the data stream with traceplus, it looks like the
cgi is submitted with a GET, but nothing is ever returned.

Is there something funny with how we make the request? Or what
data stream we accept?

Reassigning to you in the hopes you will know where the
bug should go.
-P
Assignee: pnunn → gagan
Status: ASSIGNED → NEW
Changing from [6/01] to [6/15]
Whiteboard: [nsbeta2+][6/01] → [nsbeta2+][6/15]
->ruslan
Assignee: gagan → ruslan
Yup. We've a serious problem it seems in nsSocketTransport. It entirely depends 
on the way the data is coming from the web server. It seems like we've a raise 
condition where we will stop reading after the pipe is full and not go back to 
PR_Read when the consumer read the data. I'm looking into it. It may explain 
some other partial loads and it may sometimes work or not work depending on the 
timing. UPgrading severity to critical.
Severity: normal → critical
Status: NEW → ASSIGNED
Ok. Everything is simpler then that. That particular site sends a 
bogus Content-Length header without a semicolon and we choke up on it. IE and 
NS4.x seem to tolerate this. I change the header parser to take care of this and 
will check this in when the tree opens up.
Checked in
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
This bug is verified fixed. Using today's builds, the chart displays correctly on 
Windows, Macintosh, and Linux. 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.