Add to addressbook and Attachment icons are not aligned

VERIFIED FIXED in M16

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: Henrik Gemal, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
If you have a mail with an attachment, an attachment icon appears. But the Add 
to adressebook and the Attachment(paperclip) icon are not correctly aligned.

Please see attached image
(Reporter)

Comment 1

19 years ago
Created attachment 5744 [details]
Icons not aligned

Comment 2

19 years ago
Reassign to mscott, cc jglick. Scott or Jennifer, is the problem that the icons
aren't the right size, or is this a bug in our generated XUL?
Assignee: phil → mscott
(Assignee)

Comment 4

19 years ago
When we check the new icons in, this bug should go away. Since the new icons are
the same size.

So I'm going to go ahead and mark this bug a duplicate.


*** This bug has been marked as a duplicate of 27884 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

19 years ago
Still no chance the we "open sourcer" can see this icons?
When will they be moved from http://gooey to mozilla.org????

Comment 6

19 years ago
verified as duplicate.  I'm not sure about posting these.  Jennifer?
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

19 years ago
This bug is not about the look of the icons but about the alignment.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 8

19 years ago
Right but as I said in an earlier comment the alignment was because the icons
weren't the same size. I checked in new icons for both of these buttons that are
the same size just the other day (that was the bug that we marked this as a dup
of). So now they are aligned properly.

re-closing.
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

19 years ago
Ok, but with the new images (build 2000040508) the alignment problem is still 
there.
Please see attached image.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 10

19 years ago
Created attachment 7280 [details]
new images still not aligned
(Assignee)

Comment 11

19 years ago
Wow...your eyes are better than mine. I made a style change that could fix the
problem but to be honest at normal resolutions I just can't make out the
alignment problem to figure out if I fixed it.

Can you find in your tree (release build or debug, doesn't matter), the
following file:
msgHdrViewOverlay.css

You'll see the following couple of lines:
#addToAddressBookButton {
	list-style-image:url("chrome://messenger/skin/addtoab.gif");
  min-height: 20px;
}

add the following line: margin: 0px;
So it will now look like:
#addToAddressBookButton {
  list-style-image:url("chrome://messenger/skin/addtoab.gif");
  min-height: 20px;
  margin: 0px;
}

And tell me if you can see an alignment difference? Thanks.
(Reporter)

Comment 12

19 years ago
Yes that fixed my alignment problem. Will you check it in?
(Assignee)

Comment 13

19 years ago
sure.. the tree just closed for M15 so I have to wait till it re-opens for M16.
Thanks for trying that style change out for me.
Status: REOPENED → ASSIGNED
Target Milestone: --- → M16
(Assignee)

Comment 14

19 years ago
i checked inthe style sheet change.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Updated

19 years ago
QA Contact: lchiang → laurel

Comment 15

19 years ago
Looks OK in m16 builds today:
2000-04-13-10m16 commercial build linux rh6.0
2000-04-13-10m16 commercial build mac OS 9.0
2000-04-13-09m16 commercial build NT 4.0
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.