virtualFolders.dat lost if Thunderbird is opened from mailto: link

RESOLVED FIXED in Thunderbird1.1

Status

Thunderbird
General
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Anders Betnér, Assigned: Bienvenu)

Tracking

unspecified
Thunderbird1.1
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Thunderbird version 1.0.2 (20050317) (english)

If Thunderbird is closed and you click on a mailto: link in Firefox the
virtualFolders.dat gets truncated.

Reproducible: Always

Steps to Reproduce:
1. Make sure Thunderbird is closed and set as you default mailer in windows.
2. Click on a "mailto:" link on a page in Firefox.
3. Close the message and choose "Don't save"

Actual Results:  
virtualFolders.dat contains the single line "version=1"

Expected Results:  
virtualFolders.dat should contain all my folder definitions
(Reporter)

Updated

13 years ago
Summary: virtualFolders.dat truncated if Thunderbird is opened from mailto: link → virtualFolders.dat lost if Thunderbird is opened from mailto: link
(Reporter)

Comment 1

13 years ago
I've just tried the same procedure on the latest trunk build (2005-05-27) and it
shows exactly the same behaviour. All folders are removed from
virutalFolders.dat. This really should be fixed before release. I have two
different imap accounts with different hosts defined and there are mails in
local folders imported from outlook 2003.

Comment 2

13 years ago
wow I was able to reproduce this. I didn't think I would :).

Using 05/27 nightly build. Create a saved search folder. Quit. Click on a mailto
url, then close the compose window after it comes up. The next time you start up
thunderbird, your saved search folder is gone.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → Thunderbird1.1
(Assignee)

Comment 3

13 years ago
Anders, I hate to ask, but can you try with an even more recent trunk build?
(Reporter)

Comment 4

13 years ago
No problem.
Still happens with trunk 2005-06-14
(Assignee)

Comment 5

13 years ago
I can recreate this - it's "only" imap virtual folders that are lost, so the
problem seems to be that we haven't discovered imap folders at all in this
scenario, and thus don't write them out.
Assignee: mscott → bienvenu
Status: ASSIGNED → NEW
(Assignee)

Comment 6

13 years ago
Created attachment 186341 [details] [diff] [review]
proposed fix

set a bool that says we've loaded the virtual folders, and if we haven't, don't
write out virtual folders. There are probably less direct ways of doing this,
like making sure virtual folders are always loaded when we start up, but this
seems the most robust. I checked that this works when you start up w/o virtual
folders as well...
Attachment #186341 - Flags: superreview?(mscott)

Updated

13 years ago
Attachment #186341 - Flags: superreview?(mscott) → superreview+
(Assignee)

Updated

13 years ago
Attachment #186341 - Flags: approval-aviary1.1a2?

Updated

13 years ago
Attachment #186341 - Flags: approval-aviary1.1a2? → approval-aviary1.1a2+
(Assignee)

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.