RTF Attachment getting shown inline in mail

VERIFIED FIXED in M15

Status

MailNews Core
MIME
P3
normal
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: Henrik Gemal, Assigned: rhp (gone))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
I just recieved a mail that's sent from a Outlook account and the mail has an 
attachment and the attachment gets shown inline, even though it's a .rtf file!
(Assignee)

Comment 1

18 years ago
Please attach the message source as an example. 

- rhp
Status: NEW → ASSIGNED
Target Milestone: M16
(Assignee)

Comment 2

18 years ago
Also, are you sure it't not getting shown as BOTH. 

- rhp
(Reporter)

Comment 3

18 years ago
Created attachment 5745 [details]
rtf file in mail thats get shown inline
(Reporter)

Comment 4

18 years ago
I also get a paperclip icon.
But way inline a .rtf file?
The header says:
Content-Disposition: attachment;
	filename="Telefonlste pr.14012000.rtf"
(Assignee)

Comment 5

18 years ago
Yes, we shouldn't inline an RTF file, but its still shown as an attachment so 
the only bug here is that it is getting shown inline.

- rhp
Summary: Mail is getting shown inline instead of as attachment → RTF Attachment getting shown inline in mail
(Assignee)

Comment 6

18 years ago
I have this fixed in my tree and will checkin for M15.

- rhp
Summary: RTF Attachment getting shown inline in mail → [FIXED] RTF Attachment getting shown inline in mail
Target Milestone: M16 → M15

Comment 7

18 years ago
Henrik - once rhp fixes this and marks the bug as resolved, can you do the 
verification for me?
QA Contact: lchiang → gemal
(Assignee)

Comment 8

18 years ago
*** Bug 29510 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 9

18 years ago
Just q question: Why are RTF files shown inline? Could there be problems with 
other file types?
(Assignee)

Comment 10

18 years ago
no...this was a side affect of me doing work for us to be much more forgiving 
about the exact file type and showing stuff inline. there is more positive than 
negative here...don't worry about it.

- rhp
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Summary: [FIXED] RTF Attachment getting shown inline in mail → RTF Attachment getting shown inline in mail
(Assignee)

Comment 11

18 years ago
Ok, no more inline RTF.

- rhp
(Reporter)

Comment 12

18 years ago
Verified on 2000030215
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.